cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Neo4j community edition : Server disconnected after installation?

dulsao16
Node

Hi All

I am excited to learn about neo4j and can't wait to get my hands on it. I am not too sure why I cannot get any graph out in the console ?
I have installed jdk 15 & neo4j community edition, did all the necessary login to the server to be connected.
I have set jdk 15 back to JAVA_HOME etc..

The message "You are connected as user" etc.. came up. But, I tried the default Cypher basic and click run. There is no graph output to be seen. I checked database information: connected as : disconnect: server disconnect ... username : neo4j, roles: -
Then I tried second default example : movie dataset, there is a graph. After the graph is shown, there is a message "Server is disconnected" . I have to login again.

Is it normal to have server disconnected ?
Is neo4j desktop more 'stable' than community edition which does need to do any server connections ?

I am clueless what has gone wrong and appreciate for guidance as have been meddling with the installation for 2 days.

Many thanks!

2 REPLIES 2

dana_canzano
Neo4j
Neo4j

certainly not expect but..

  1. what version of Neo4j is in play here?
  2. jdk 15 ???? im not aware of Neo4j being supported under JDK 15. It may ? it may not ?? but at least per System requirements - Operations Manual which is the documentation for Neo4j 4.2 the requirements indicate
It is required to have a pre-installed, compatible Java Virtual Machine (JVM), to run a Neo4j instance.

Table 7. Neo4j version and JVM requirements.
Neo4j Version	JVM compliancy
3.x                       Java SE 8 Platform Specificaton
4.x                       Java SE 11 Platform Specificaton

now maybe Java 15 has nothing to do with the server disconnects. maybe? needless its not on the tested/supported platform

dulsao16
Node

Hi,
Many thanks for your help!
I am unsure why I am still encountering the same issue as of today.
The following actions I have done :
-Installed jdk 11 and redirect through environment variables

  • Launch neo4j web browser program using the default port. Same issue '' Server is disconnect" .
    -Installed neo4J desktop to try but found the same issue "Server is disconnect"

Much grateful if there is a light shed.

Thank you very much!