Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Neo4j-admin tool backup offline DBMS

Node Link

I cannot understand how to backup my DBMS from Neo4j desktop.
The Operations Manual is very confusing

Here: Neo4j Admin - Operations Manual
Neo4j Admin is located in the bin directory and is invoked as: neo4j-admin <command>
But from where "invoke" the command?

And here: Back up an offline database - Operations Manual
"The command can be run only locally from an online or an offline Neo4j DBMS. "
" The target directory /dumps/neo4j must exist before running the command and the database must be offline."
These two sentences are on the same page!

Please help!
Thanks, Elisabeth



Hi @ekaske

The easiest way is to select "Dump" from "..."
Or Select "Terminal" for backup command.

Node Link

Hi Koji, thank you so much for your help. Unfortunately it did not work.

  1. There is no "Dump" in my "...", only "Clone" and "Remove"
  2. I tried Terminal, using the syntax of the manual. But I always get the answer:
    "Der Befehl "dump" ist entweder falsch geschrieben oder konnte nicht gefunden werden."
    Same with "backup", meaning the system does not know these commands.
    I am new to databases and coding and use only a local version to display an old Chinese game 陞官圖 in a network graph for research purposes. I wonder whether some functions work only for the paid version, but a backup would be a rather vital function, right?

Hi @ekaske
My Neo4j Desktop version is 1.4.9.

In the terminal, you can write the dump command as follows.

Please modify <Backup Directory> and <File Name>.

If your Neo4j version is earlier than 4.0 you have to rewrite the database name from "--database=neo4j" to "--database=graph.db".

bin/neo4j-admin dump --database=neo4j --to=/<Backup Directory>/<File Name>.dump

Node Link

Hi, this worked, after I changed slash / to backslash . Thanks for help. I appreciate it. Best, Elisabeth

Graph Voyager

In V1.4.8 of the Desktop I used to be able to dump the database from the Desktop. Now that I've installed V1.4.9, the dump fails.

Same here. But the method suggested by Koji eventually worked.

Hi @mbandor

My Neo4j Desktop version is 1.4.9.
The "Dump" works!!

Node Link

I see. Sorry, just realized that my version is 1.4.5. Updates have always failed, but I'm happy with every workaround that works. Thanks again.

Nodes 2022
NODES 2022, Neo4j Online Education Summit

All the sessions of the conference are now available online