cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Neo4j-admin failing due to Java version (Community Edition on Mac)

Neo4j Desktop 1.4.15, Community Edition 4.4.3 on Mac Catalina
I want to use neo4j-admin for various things like consistency-check and backup.
All neo4j-admin commands complain about the Java version.

Selecting JVM - Version:16.0.2+7-67, Name:Java HotSpot(TM) 64-Bit Server VM, Vendor:Oracle Corporation
WARNING! You are using an unsupported Java runtime.
* Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.
* Please see https://neo4j.com/docs/ for Neo4j installation instructions.

Exact error messages usually include:

Java HotSpot(TM) 64-Bit Server VM warning: Option UseBiasedLocking was deprecated in version 15.0 and will likely be removed in a future release.

Exception in thread "main" java.lang.LinkageError: Cannot to link java.nio.DirectByteBuffer

It shows the following::

VM Name: Java HotSpot(TM) 64-Bit Server VM
VM Vendor: Oracle Corporation
VM Version: 16.0.2+7-67
JIT compiler: HotSpot 64-Bit Tiered Compilers

My java --version shows:

java 16.0.2 2021-07-20
Java(TM) SE Runtime Environment (build 16.0.2+7-67)
Java HotSpot(TM) 64-Bit Server VM (build 16.0.2+7-67, mixed mode, sharing)
  1. Does Community Edition support neo4j-admin? I think I've used it in the past.

  2. Does 1.4.15 / 4.4.3 really require old Java 11 ???

  3. If so, can I install more than one Java, and point Neo4j to 11?

  4. If not, how do I get neo4j-admin to respect Java 16

7 REPLIES 7

sameer_gijare14
Graph Buddy

Have you tried this on java 11?
Mr Sameer G

No, that's why I'm asking. I don't want to downgrade Java for my whole machine if there is some way to have neo4j-admin be compatible with a current version.

@roger.worden

System requirements - Operations Manual describes the java requirements for Neo4j 4.4.x and that being Java 11 only

Is there a Neo4j config parameter to point it to a specific Java installation on my machine? That way I could install Java 11 just for Neo4j and use Java 16 for other apps that require it.

Debug log shows these lines, so I guess it does have its own JVM version 11 at sun.boot.library.path = /Users/-----/Library/Application Support/Neo4j Desktop/Application/distributions/java/zulu11.54.25-ca-jdk11.0.14.1/zulu-11.jdk/Contents/Home/lib

3X_f_6_f6b25b52e4dfb3c9123bde88529c7d404b088d70.png

Hello @roger_worden , I am having the same problem with you - just wonder how you point neo4j to java11,?

Many thanks!

MK

 

 

mengjiakang2017
Node Clone

Hi @roger_worden , I was able to update the java home path to jdk11 from the default java18 following this - https://mkyong.com/java/how-to-set-java_home-environment-variable-on-mac-os-x/ section 6