cancel
Showing results for 
Search instead for 
Did you mean: 

Neo.ClientError.Statement.SyntaxError

IchsanALi
Node Link
load csv with headers from 
with row where row.Launched starts with '2016'
MERGE (p:Project {id:row.ID})
ON CREATE SET
p.name = row.Name,
p.launched = date(substring(row.Launched,0,10))
p.deadline = date(row.Deadline)
p.state = row.State;
 

Neo.ClientError.Statement.SyntaxError

Invalid input 'p': expected whitespace, comment, '.', node labels or rel types, '[', '^', '*', '/', '%', '+', '-', "=~", IN, STARTS, ENDS, CONTAINS, IS, '=', "<>", "!=", '<', '>', "<=", ">=", AND, XOR, OR, ',', ON, USE GRAPH, LOAD CSV, START, MATCH, UNWIND, MERGE, CREATE UNIQUE, CREATE, SET, DELETE, REMOVE, FOREACH, WITH, CALL, RETURN, UNION, ';' or end of input (line 8, column 1 (offset: 236))
"p.deadline = date(row.Deadline)"
 
 
1 ACCEPTED SOLUTION

glilienfield
Ninja
Ninja

You are missing commas after sett property you are setting in the ‘on create set’.  The line feed does substitute the need for a deprecating comma. 

View solution in original post

2 REPLIES 2

glilienfield
Ninja
Ninja

You are missing commas after sett property you are setting in the ‘on create set’.  The line feed does substitute the need for a deprecating comma. 

can run,

thank's