cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

Movie Database Does Not Start

okanbzkrt
Node

I just installed neo4j desktop and tried to run movie database but it gives error. Version is 4.1.0
Windows 10. I could not understand what is wrong from logs.
Database failed to start: DB [database-5db1a868-35bf-44e0-a100-13442dfbbbe6] 'v4.1.0' exited with status 'KILLED'. Check the logs
This is the log:
2020-07-16 09:07:58.862+0000 INFO Starting...
2020-07-16 09:08:01.998+0000 ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address. Supported CypherOperatorEngineOption values are: compiled, interpreted
org.neo4j.exceptions.SyntaxException: Supported CypherOperatorEngineOption values are: compiled, interpreted
at org.neo4j.cypher.CypherOptionCompanion.$anonfun$apply$1(CypherOption.scala:43)
at scala.Option.getOrElse(Option.scala:189)
at org.neo4j.cypher.CypherOptionCompanion.apply(CypherOption.scala:43)
at org.neo4j.cypher.CypherOptionCompanion.apply$(CypherOption.scala:42)
at org.neo4j.cypher.CypherOperatorEngineOption$.apply(CypherOperatorEngineOption.scala:24)
at org.neo4j.cypher.internal.CypherConfiguration$.fromConfig(CypherConfiguration.scala:66)
at org.neo4j.cypher.internal.CypherConfiguration.fromConfig(CypherConfiguration.scala)
at org.neo4j.fabric.bootstrap.FabricServicesBootstrap.bootstrapServices(FabricServicesBootstrap.java:127)
at com.neo4j.enterprise.edition.EnterpriseEditionModule.bootstrapFabricServices(EnterpriseEditionModule.java:272)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.build(DatabaseManagementServiceFactory.java:137)
at com.neo4j.server.enterprise.EnterpriseManagementServiceFactory.createManagementService(EnterpriseManagementServiceFactory.java:38)
at com.neo4j.server.enterprise.EnterpriseBootstrapper.createNeo(EnterpriseBootstrapper.java:20)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:117)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:87)
at com.neo4j.server.enterprise.EnterpriseEntryPoint.main(EnterpriseEntryPoint.java:25)
2020-07-16 09:08:02.000+0000 INFO Neo4j Server shutdown initiated by request

1 ACCEPTED SOLUTION

UtkuErdemir
Node Link

Hi again,

I solved the problem. It is about the JDK. If you add your DB settings this line, it will be solved.

Configuration:
dbms.jvm.additional= -Duser.country=EN -Duser.language=EN -Duser.variant=Traditional_WIN

It is changing JVM's language and we don't have to change our system language.

Have a good day.

View solution in original post

31 REPLIES 31

webtic
Graph Fellow

Something is blocking the server to start a database web interface on port 7474.
Could it be that there is another instance already running?

Error is only with version 4.x.x databases. I can start server with databases 3.5.x versions. So there is not another instance running already.

Mmm could you post the bit of the neo4j.conf where dbms.default_listen_address is mentioned?

I am a newbie by the way I don't know if I am at the correct config file.
I opened the neo4j.conf file at Users.....Neo4jDesktop\neo4jDatabases\database-1d23d0fd-81d0-4793-a790-f31a263f31fd\installation-4.1.0\conf and this is the line with
dbms.default_listen_address
#*****************************************************************

Network connector configuration

#*****************************************************************

With default configuration Neo4j only accepts local connections.

To accept non-local connections, uncomment this line:

#dbms.default_listen_address=0.0.0.0

and these are the other setting if that helps:

Bolt connector

dbms.connector.bolt.enabled=true
#dbms.connector.bolt.tls_level=DISABLED
#dbms.connector.bolt.listen_address=:7687

HTTP Connector. There can be zero or one HTTP connectors.

dbms.connector.http.enabled=true
#dbms.connector.http.listen_address=:7474

HTTPS Connector. There can be zero or one HTTPS connectors.

dbms.connector.https.enabled=false
#dbms.connector.https.listen_address=:7473

Also I tried to locate same setting with installation 3.5.19 (which is running ok) but there is not a setting involving dbms.default_listen_address with that version.

Jsut to clear up things a bit:
You are using the Neo4J desktop application and this happens with a newly created db?

Yes. I downloaded Neo4j desktop, installed it. Tried to start the movie database which comes wtih the installation to teach about graph databases but it gives the error I mentinoed. Also whenever I try to create a new database with version 4.x.x it gives the same error. However when I try to create a database with version 3.x.x it is working.

it's worked to me!!
dbms.jvm.additional= -Duser.country=EN -Duser.language=EN -Duser.variant=Traditional_WIN

wadael
Node Clone

In doubt, reboot
Weird log. It mixes port and cypher interpreter variant as if there would be a syntax error in a cypher query.

mousco
Node

I have the same exact problem with Neo4j Desktop 1.3.3 & specifically DB version 4.1.0

I have the same problem. Has anyone solved it?

I've updated Neo4j, uninstalled and reinstalled it, and updated my Java per a friend's recommendation.

Is this problem local to my machine, or something universal as others have the same problems?

Thanks!

I found another article and followed the instructions to kill the process. My database started successfully.

Not worked for me. My problem continues with databases version 4.

UtkuErdemir
Node Link

Hi Okan,

I guess you are using operation system in Turkish language. I think this problem about your operating system's language. If you switch your operating system language to English. Your problem will be solved.

Have a good day.

Thanks Utku, it worked after switching to English. But what is the problem exactly in Turkish language? any ideas?

UtkuErdemir
Node Link

I don't know but i am researching this error's reason. Maybe it is due to the JDK. Android Studio has a same language problem too. It's a Java based Application. Already i found this answer from my Android Studio experience. If i find any new answer, i will write to this topic. If you find anything too can you write this topic?

UtkuErdemir
Node Link

Hi again,

I solved the problem. It is about the JDK. If you add your DB settings this line, it will be solved.

Configuration:
dbms.jvm.additional= -Duser.country=EN -Duser.language=EN -Duser.variant=Traditional_WIN

It is changing JVM's language and we don't have to change our system language.

Have a good day.

opened an account just to thank you

It works, thank you Utku

Thank you very much.

Can you tell me please which file should I change this? I am using 1.3.11 on Windows 7. Also using JDK10

Hi, if you are using JDK 10 maybe Neo4J 4.+ doesn't start. Because i saw in somewhere it required least JDK 11. Despite i can give an answer to your question.

Steps:

  • Open your Neo4j Desktop.
  • You will see your Database.
  • It has a three dots in the right corner. Click it.
  • Open the manage.
  • You should see settings tab and click it. Then write that arguments.

Have a good day.

It didnt work. I have changed jdk to version 11. Then also same result. Shows to change the port..fixing it also not working

Hi again,

This solution about language problem in the JDK. If you are using English language or if your language's doesn't contain any special chars this solution will not working. You should check your logs and if it is different this topic's first message should open new topic.

Have a good day.

Hi there,
Sorry I didnt have the language issue. My database is not starting after installation as in the first thread. I am using OS in English only

Hi utku, thank you for your solution. You saved my time :))

I followed all the suggestions described above, but still the issue is there as soon as I instal APOC plugin

I am having the same issue. Neo4j prompted to fix config issue then killed the session before it started.
installed the update and still had the same issue
Cheers
R

rpwillia0
Node

I am having a similar problem starting up a brand new DB. To start fresh I wiped out my neo4j install, downloaded the most recent and installed. When it comes up I try to start the movie database and it fails every time. Here is what is in the log; I just don't see anything obvious that should be a show stopper.

[2020-12-29 13:08:51.613] [info] Starting Neo4j
[2020-12-29 13:08:51.614] [info] Starting db [database-2b62a6e5-f570-4e23-9808-2979a73f5627] 'v4.1.3'
[2020-12-29 13:08:51.630] [info] Executing 'java' [
'-cp',
'"C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\plugins\;C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\lib\"',
'-Xms512m',
'-Xmx1G',
'-server',
'-XX:+UseG1GC',
'-XX:-OmitStackTraceInFastThrow',
'-XX:+AlwaysPreTouch',
'-XX:+UnlockExperimentalVMOptions',
'-XX:+TrustFinalNonStaticFields',
'-XX:+DisableExplicitGC',
'-XX:MaxInlineLevel=15',
'-Djdk.nio.maxCachedBufferSize=262144',
'-Dio.netty.tryReflectionSetAccessible=true',
'-Djdk.tls.ephemeralDHKeySize=2048',
'-Djdk.tls.rejectClientInitiatedRenegotiation=true',
'-XX:FlightRecorderOptions=stackdepth=256',
'-XX:+UnlockDiagnosticVMOptions',
'-XX:+DebugNonSafepoints',
'-Dfile.encoding=UTF-8',
'com.neo4j.server.enterprise.EnterpriseEntryPoint',
'--home-dir="C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4"',
'--config-dir="C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\conf"'
]
[2020-12-29 13:09:04.429] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-12-29 13:09:04.802] [info] [1] Online check response: 200 version: 1.3.11
file
[2020-12-29 13:09:27.379] [info] Checking ports
[2020-12-29 13:09:37.119] [info] Checking ports
[2020-12-29 13:09:37.449] [info] Starting Neo4j
[2020-12-29 13:09:37.450] [info] Starting db [database-2b62a6e5-f570-4e23-9808-2979a73f5627] 'v4.1.3'
[2020-12-29 13:09:37.464] [info] Executing 'java' [
'-cp',
'"C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\plugins\;C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\lib\"',
'-Xms512m',
'-Xmx1G',
'-server',
'-XX:+UseG1GC',
'-XX:-OmitStackTraceInFastThrow',
'-XX:+AlwaysPreTouch',
'-XX:+UnlockExperimentalVMOptions',
'-XX:+TrustFinalNonStaticFields',
'-XX:+DisableExplicitGC',
'-XX:MaxInlineLevel=15',
'-Djdk.nio.maxCachedBufferSize=262144',
'-Dio.netty.tryReflectionSetAccessible=true',
'-Djdk.tls.ephemeralDHKeySize=2048',
'-Djdk.tls.rejectClientInitiatedRenegotiation=true',
'-XX:FlightRecorderOptions=stackdepth=256',
'-XX:+UnlockDiagnosticVMOptions',
'-XX:+DebugNonSafepoints',
'-Dfile.encoding=UTF-8',
'com.neo4j.server.enterprise.EnterpriseEntryPoint',
'--home-dir="C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4"',
'--config-dir="C:\Users\Megan\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-2dc32530-c4e4-4e8f-aadb-f865a43791e4\conf"'
]
[2020-12-29 13:09:44.446] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-12-29 13:09:44.818] [info] [1] Online check response: 200 version: 1.3.11
file
[2020-12-29 13:10:24.457] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-12-29 13:10:24.843] [info] [1] Online check response: 200 version: 1.3.11
file
[2020-12-29 13:10:49.444] [info] Process [10972] exit with code '1', signal 'null'
[2020-12-29 13:10:49.458] [info] Process [6988] exit with code '1', signal 'null'
[2020-12-29 13:11:04.460] [info] [1] Online check request: https://dist.neo4j.org/neo4j-desktop/win/latest.yml
[2020-12-29 13:11:05.361] [info] [1] Online check response: 200 version: 1.3.11

Hi, I recently experienced the same issue reported by Okan. The error reported by Neo4j is not very clear (it complains about not being able to open a socket on dbms.connector.http.listen_address). However, the problem was simply that my default Java version was still set to Java 8 but as soon as I changed it to Java 11 the database was able to start up OK. This is because Neo4j 4.x requires Java 11.

I hope this helps.

  • Dave

I am having the same problem that was reported by Okan and David Brennan others.

Community version of Neo4j fails to start. "ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address"

I tried updating the language to English, am on JDK 16, checked to ensure that no other Neo4J is running concurrently.

Some details
Windows 10 OS
neo4j-community-4.2.4
JDK 16
clean installation
neo4j is not executable from windows search; CLI ".\bin\neo4j.bat console -verbose" results in " ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address"

tayco
Node

Thanks @UtkuErdemir .
You saved my day.
My operating system language is turkish too.