Showing results for 
Search instead for 
Did you mean: 

Migrate data from 3.5.6 Community to 4.2.7 Community

Node Clone


I originally posted questions about a 3.5.1 --> 4.0.0 upgrade here: Migrate data from 3.5.1 Community to 4.0.0 Community

I am now trying to do the same thing in upgrading Community 3.5.6 to Community 4.2.7.

I have set everything as suggested in the video, and when I run via cmd prompt on my local windows 10 machine ...\bin> neo4j console, I receive this error...
"Error upgrading database.Database left intact and will likely not be able to start: org.neo4j.hernel.impl.storemigration.StoreUpgrader$DatabaseNotcleanlyShutDownException: the database is not cleanly shutdown.".

As stated in the previous forum thread, it seem that need to delete 2 separate neostore.transaction.db.XX files found in my neo4j-community-xxx > data > databases > [dbname] folder. I have deleted these file like last time, but I am still receiving the same error about 'not cleanly shutdown'.

How can I do a 'clean shutdown' on my local cmd prompt? (this might be a separate issue in there does not appear to be solid documentation on how to do a clean shutdown using a local cmd prompt when your neo4j db has been started with "neo4j console". What is the clean shutdown in this scenario?)
Or what 'transaction' files do I need to delete?
Or can I set up neo4j.conf with an upgrade property of "upgrade_shutdownwasclean?: dont-care"?

What am I doing wrong in this upgrade?



debug.txt (83.9 KB)


Node Clone

Follow Up On Clean ShutDown:

Using the cmd line against neo4j-community-3.5.6\bin I ran: neo4j install-service so I could then run neo4j start and neo4j stop, thus providing for a clean shutdown.

Then I transferred the data files as expressed in the video, and now against neo4j-community-4.2.7\bin I ran: neo4j console and while I no longer get an error around 'clean shutdown', I get this information that tells me my error is now "UnableToUpgradeException", and when I look in the log file I see something about...

Label with id=15 not found

What does this mean, why do I need to have this missing id=15 reconciled? and how do I reconcile it?

Node Clone

Unfortunately, I've given up. In the end it was easier to import my data into 4.2.7 via csv files.

Nodes 2022
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.