Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Issues with neo4j-admin import


I need to import 14 mil. nodes from a csv.
After some efforts with threaded apoc.import.csv, came upon the import using neo4j-admin
at this link Importing CSV Data into Neo4j - Developer Guides

Well, it did import all 14mil nodes in like 2 minutes,

but!....database (4.2.6) is now dead, won't start:

"DBMS failed to restart: Error: Could not call remote method 'databaseStatistics'. Check that the method signature is correct. Underlying error: Cannot destructure property 'nodes' of 'e[0]' as it is undefined. Underlying stack: TypeError: Cannot destructure property 'nodes' of 'e[0]' as it is undefined. at t.default.databaseStatistics (D:\Program Files\Neo4j Desktop\resources\app.asar\dist\ at electron/js2c/browser_init.js:6651:63 at EventEmitter. (electron/js2c/browser_init.js:6504:21) at EventEmitter.emit (events.js:203:13) at EventEmitter.emit (domain.js:476:20) at WebContents. (electron/js2c/browser_init.js:3871:23) at WebContents.emit (events.js:203:13) at WebContents.EventEmitter.emit (domain.js:476:20) at WebContents.emitter.emit (D:\Program Files\Neo4j Desktop\resources\app.asar\node_modules@sentry\electron\src\main\integrations\electron.ts:78:18) at WebContents.topLevelDomainCallback (domain.js:131:23)"

Note 1: did the same (confing, setup) with 4.2.5 and it worked. Will try again with 4.2.6
Note 2: worked also with 4.2.6 - this time i've ramped up all possible RAM usage, meaning

The only difference between 3 try and first try (which failed) is in the pagecache, which I've left to the default 512m.


Node Link

Dear Gabriel,
could it be related to this?
Do you see in your debug.log the following:

java.lang.RuntimeException: org.neo4j.kernel.impl.transaction.log.entry.UnsupportedLogVersionException: Log file contains entries with prefix 2, and the lowest supported prefix is 3. This indicates that the log files originates from an older version of neo4j, which we don't support migrations from

@frederik.byl thanks for the hint, i'll check

I am getting Cannot destructure property 'nodes' of 'e[0]' as it is undefined. at t.default.databaseStatistics (C:\Program Files\Neo4j)
I noticed when change configuration in Neo4j.conf and comment all network settings
i just leave:
but when i attemp to set the bolt and http ports the error appears. Weird, because the DB was working fine with no changes at all in the data. All I actually did is I added another DB in terms of change