cancel
Showing results for 
Search instead for 
Did you mean: 

Issues installing bloom to neo4j enterprise server

mason_edmison
Node Link

I am trying to install neo4j bloom to a neo4j enterprise server.

The .jar is placed within $NEO4J_HOME/plugins with correct permission and my bloom.license file is placed in NEO4j_HOME.

I have updated the neo4j.conf follow like:

dbms.unmanaged_extension_classes=com.neo4j.bloom.server=/bloom
#bloom and browser to http_allowlist
dbms.security.http_auth_allowlist=/,/browser.*,/bloom.*
dbms.security.procedures.unrestricted=apoc.*, bloom.*, gds.*
neo4j.bloom.license_files=/var/neo4j/neo4j-enterprise-4.2.3/bloom.license
neo4j.bloom.authorization_role=admin,architect,reader

With the above configuration and files however, I receive an error of

The Neo4j Bloom Server plugin is missing. A licensed plugin is required for remote graphs. Please contact your system administrator or your Neo4j representative.

when trying to login into bloom at http://<neo4j_server_url>.com:7474/bloom.

The above message is not clear to me as I do have the plugin in the plugin dicrectory - perhaps I have fudged something in the config file? Can someone please advise?

versions info:
neo4j==4.2.3
bloom (jar)==4.x-1.5.1

Thanks in advance

3 REPLIES 3

clemens_anzmann
Node Link

Hi @mason.edmison,

thanks for reaching out!
It looks like the license file path setting is slightly misspelled. The correct spelling is

neo4j.bloom.license_file=/var/neo4j/neo4j-enterprise-4.2.3/bloom.license

without the "s" at the end of "file".
Does this fix the issue for you?

Many thanks,
Clemens

Hi. I made the suggested change in the neo4j conf like:
neo4j.bloom.license_file=/var/neo4j/neo4j-enterprise-4.2.3/bloom.license
(and restarted the database) and still receive the same error.

clemens_anzmann
Node Link

Hi @mason.edmison,

thanks for your reply.
As far as I can tell, the settings look valid. I can think of two things to try next:

  • using a relative path for the license file instead of an absolute path (since the license file is inside the database's install directory, this would mean changing the setting to neo4j.bloom.license_file=bloom.license)
  • checking that neo4j.bloom.license_file is only present once and not set anywhere else in neo4j.conf

I hope this helps with tracking down the issue.
Many thanks,
Clemens

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.