cancel
Showing results for 
Search instead for 
Did you mean: 

How to set properties in a bloom search phrase?

Jean
Node Link

Hi all,
I'm new to Neo4j and Bloom, I need to set properties in a bloom search phrase so that I can customise the visualization effect with them later. For example, the following CQL with the movies graph is O.K. in Neo4j Browser:

MATCH (tom {name: "Tom Hanks"}) set tom.sex="male" RETURN tom

But when I define a search phrase in Bloom, I'm warned that:
This query manipulates data.
This will disable node query limiting from the settings and instead process the first 1000 records from the result set.

And when I execute the search phrase, I'll get an Erorr saying that "Writing in read access mode is not allowed".

Any idea is appreciated, thanks in advance.
Best regards.
Jean

3 REPLIES 3

angeliki_komian
Node Link

You can, in general, manipulate data in Neo4j Bloom.
About the first message (This query manipulates data.
This will disable node query limiting from the settings and instead process the first 1000 records from the result set.) it’s just a warning in order to inform the user that we disable the limit applied to the existing query as we do in different cases (when we fetch data only).
About the second message (Writing in read access mode is not allowed) it seems that dbms.read_only setting is enabled in the settings configuration.

Hi Angeliki,
I'v checked the neo4j.conf file and uncommented the line "dbms.read_only=false", it means set it to false, but still get the same error message.
It seems that it isn't the cause. Thanks anyway, Merry Christmas!
Jean

thanks, an other thing you can check is the role permissions of the user you connect in Bloom in case it's different than that you connect in Browser.

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.