cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

How to set apoc.import.file.enable=true?

reeyarani17
Node Clone

i use desktop version 4.2.1 in neo4j.I want to import the json file. it is showing me the error --
Neo.ClientError.Procedure.ProcedureCallFailed
Failed to invoke procedure apoc.import.json: Caused by: java.lang.RuntimeException:
Import from files not enabled,
please set apoc.import.file.enabled=true in your apoc.conf

i have configured in the neo4j in settings and enabled it there but it is still not working.Then i saw in the apoc list that is is false?Can i change it here by some ways?

6 REPLIES 6

koji
Ninja
Ninja

Hi @reeyarani17

Click "..." and select "Settings"

And add "apoc.import.file.enabled=true" to the last line.

#********************************************************************
# Other Neo4j system properties
#********************************************************************
apoc.import.file.enabled=true

Then restart the db.

i had tried this way but it did not work for me.

koji
Ninja
Ninja

This is the best way to create the "apoc.conf" in conf folder.
And write "apoc.import.file.enabled=true" to the conf.

Am i doing it wrong?I am writing the file in notepad with correct extension and then adding files to the neo4j desktop!I tried invoking the json file by call apoc.load.json("file link ")
Now also the error is showing.

Failed to invoke procedure apoc.load.json: Caused by: java.lang.RuntimeException: Import from files not enabled, please set apoc.import.file.enabled=true in your apoc.conf

I may be missing some minor point since i am new to this.
Thankyou so much for your response !

Hi @reeyarani17

Is the cause not restarting the DB?

My Environment

macOS BigSur
Neo4j Desktop 1.4.2
Neo4j 4.2.3

1: Created the DB
2: Check the status

CALL apoc.config.list
"apoc.import.file.enabled"	"false"

3: CALL apoc.load.json

Failed to invoke procedure `apoc.load.json`: Caused by: java.lang.RuntimeException: Import from files not enabled, please set apoc.import.file.enabled=true in your apoc.conf

4: Add apoc.conf

Create ./conf/apoc.conf
apoc.import.file.enabled=true


5: Restart the DB

6: Check the status

CALL apoc.config.list
"apoc.import.file.enabled"	"true"

7: CALL apoc.load.json

thankyou for such a descriptive response

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

All the sessions of the conference are now available online