cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

How to configure the bolt.outbound_buffer

zhyinjun
Node

We are using Neo4j v4.3.2, recently we faced the "Bolt connection [%s] will be closed because the client did not consume outgoing buffers for %s which is not expected." issue.

Finally, we found this page, https://neo4j.com/developer/kb/bolt-throttling/, it mentions the below configuration.

unsupported.dbms.bolt.outbound_buffer_throttle=true
unsupported.dbms.bolt.outbound_buffer_throttle.high_watermark=512k
unsupported.dbms.bolt.outbound_buffer_throttle.low_watermark=128k
unsupported.dbms.bolt.outbound_buffer_throttle.max_duration=15min

My question is how can we get the "correct" value to be set in the above configuration? Via the size of the return data? 

1 REPLY 1

We are facing the same error since some times too, now on version 4.4.13. Would be terrific if Neo4j can share the correct values for those settings to avoid this issue.