Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app


Hi, Everyone I have come around with an issue regarding error which I got when today I got update of Neo4j Desktop. After Update my Neo4j browser is not working. It say the following error "Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app." I also re-installed Neo4j desktop still getting same error. Can anyone help me out to resolve this issue. I tried some googling but the suggestions didn't fit for my cast.
Gracias and Regards: Siraj Munir (Neo4j Lover)


Desktop 1.1.17 is released, try a upgrade.

View solution in original post



I think there is something wrong with the latest update

It's definitely a bug. Stay tuned for a another update fixing this.

How long it would to the next update ?

Desktop 1.1.17 is released, try a upgrade.

Got it. Let me test it

Love you man. Working great

It's not me, it's our wonderful "desktop team".

Sure thing "Team" is what all we need for "to the rescue" tasks

Nope. Nada. Nyet. 1.1.17 ( is not the solution. Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.

I have the same problem. When I install today's version of Desktop, I get the following screen:

which suggests I have installed v3.2.18, but if I exit and restart the Desktop, it says I am using v3.2.17, and I get the "Damaged" error message.
Oh, and I can't log on to localhost 7474.
I'm using a win10 system.
Any thoughts?

The "Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.
" error is still occurring on Version 1.1.17 (


I am also getting this error with the Version 1.1.17 ( I have tried to reinstall, closed all browsers, restarted machine etc.

Node Link

I too have run into this issue. I downloaded and created my first graph yesterday...used the browser for a few hours. Today, after restarting neo4j, I receive the error about the damaged browser. I see no way to resolve the issue, so I am now dead in the water. Sad. I'm running on Mac OS Mohave 10.14.3. Here's a screenshot...notice the spinner below the Browser in the list of Apps.

Unfortunately, it is not solved: I installed today the neo4j desktop system completely after this error message ("Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app." ). I removed all directories with neo4j. Then, it startet properly. Nevertheless, I stopped my server and restarted it now and get the message again.
What the real solution of this problem?

Node Link

This should be unmarked as "solved." It is not.

I’ve only had the latest version installed. Tried reinstalling. Same error when starting the browser. Software is unusable in this state.

It was marked as solution as it resolved my problem. I ran into same problem with the previous update i.e. 1.1.16 and the newer update resolved my issue. My system config is win10 64bit Neo4j Desktop version 1.1.17 and my Neo4j browser version is 3.2.18 and it's working fine.


I installed Neo4j Desktop in Windows 10 yesterday. Because of this error, I uninstalled and reinstalled it, then the error occurred again after awhile. I am using the version 1.1.17 in Ubuntu 18.04 now, and it seems OK. I've had no problem since yesterday.

EDIT: I'm getting the same error in Ubuntu right now.

Node Clone


I've met same problem, and find workaround.

  • Start database from Neo4j Desktop(Windows 10 + N4JD 1.1.17)
  • Open http://localhost:7474 on your browser(Chrome, Firefox, etc) instead of Neo4j Browser

This is the only workaround currently helping

Node Link

For you who it's not working for in Desktop v1.1.17: What version of Neo4j Browser do you have installed?
If you're on the latest (neo4j-browser v3.2.18), go to the Desktop data folder and try to delete the Application/graphApps/neo4j-browser folder and restart Neo4j Desktop and see if that makes a difference.


I am also having same problem from Friday. I am using neo4j-browser v3.2.17 and Desktop v1.1.17 in Windows 10. I tried deleting the folder as you said. It unfortunately didn't make a difference. In the log file, I see the following.
[2019-03-18 12:30:42:0489] [error] Graph-App 'Neo4j Browser' execution blocked: signature verification failure.

Error: Installed Graph-App signature has been changed.
at f (C:\Users\AppData\Local\Programs\Neo4j Desktop\resources\app.asar\dist\
at process._tickCallback (internal/process/next_tick.js:68:7)

And btw I have no idea how to update the browser to v3.2.18.. Thank you.

Could you close Neo4j Desktop, start it and then grab the log file and send it to me please?

Mailed you the log file..

Hello again,

I manually downloaded and added the Browser v3.2.18(from the url in the log file) and it works. However the browser v3.2.17 still gives me the same error (and also there is no way to remove it from the Application panel).

Thanks for the info!
Yes, it's the update that is failing for some reason. We are investigating at the moment.

The workaround for people having this issue is, as you say, install latest neo4j-browser as a separate graph app using:

This works for me, Thanks!

Hey! I am on Windows platform.
Can you tell me how to install the package separately?

Hey.. In Neo4j desktop, select the Graph Applications tab in the side panel. Paste the URL (above) and install. And then you can add it in your project (Add Application)..

Hi @gaganpree99 ,

1.- once you installed Neo4J Dektop,
2.- Click on the "Graphs Application" button on the left side panel.
3.- At the left-bottom of the window you will see "Install Application" text box and add paste the following Graph App URL
4.- Now return to the projects page (Projects bottom at the top left side panel).
5.- in the main gray window click in "+ Add Application" and selecte Neo4j browser 3.2.20.

Please let me know if it works for you.


Just one more comment, to launch the Graph in your desktop (basic instructions from point 2. in this blog )

6.-You have to create a graph (in the main window, type into the subwindow "+ Create graph" -you add the title of the graph and the password. Once created click on the symbol "Play"
7.- and later in the link "Management" it will open a window where you can see in the top, "Open in browser". that wont work. you have to copy and paste in the browser: http://localhost:7474 -info also provided here.

Thanks. This is working. Can you let us know how to uninstall 3.2.17 browser and make the new one as default

I am running on a MacBook, and I have Desktop 1.1.17 and Browser 3.2.17.

(Attachment log.log is missing)

Node Link

Also, please send me your log files (ctrl or cmd + k and type 'log') and select desktop log file to get to it. I'm available at oskar.hane at

Node Link

Indeed the workaround works, however just so that you know, you will loose your saved scripts 😞 .. most probably there is some way to retrieve them in some configuration file, I did not have time to look for them.

I got the same question with the v1.1.7 when I re-installed the application. It runs fun at the first time I install the app. I re-install the app with some other problem. But when the second installing finished, I can't create a Graph with the problem 'Database failed to create: Error: Could not change password'. I tried to click the Neo4j browser I got 'Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app'. Waiting for the solution.

can you check in ~/Library/Application Support/Neo4j Desktop/Application/graphapps and delete the two browser entries there,

and also from the JSON file in ~/Library/Application Support/Neo4j Desktop/Application/persist/graphapps.json

I did that yesterday and then it worked after a restart

Deleting the entry worked for my, like so:

rm -rf ~/Library/Application\ Support/Neo4j\ Desktop/Application/graphApps/_global/neo4j-browser/

Thank you!

@danvalencia It's working, thanks.

This works for me!!!
I can't believe neo4j still has this bug in June, 2020. Hope neo4j will solve this problem quickly.

Node Clone

Thanks for the info..I had this problem as well. Installed 3.2.18 but had to manually delete the old version folder in the graphapps directory for the problem to go away. All good now..i hope!

I am facing the same problem.
Graph App 'Neo4j Browser' is damaged and can't be opened. please re-install the app
I have uninstalled and installed application several times but still same error. This is really annoying now.

I am using Neo4j Desktop - 1.1.17 on my machine.
Can anyone help?

Node Link

It actually keeps happening very often, last week itself I clean installed it and today again it's giving same issue.

I'm a new user and am having the same issue - have reinstalled three times now. It was working originally about a week ago but I don't know what changed.

Node Link

What worked me to solve above problem is clearing neo4j desktop configurations which in Mac are located at ~/Library/Application\ Support/Neo4j\ Desktop/ and ~/.neo4j.

BTW before deleting above configuration files you would need to quit neo4j desktop if it's running.

@vinitpayal, this works, but be careful when you use this solution. THIS WILL DELETE ANY LOCAL GRAPHS THAT YOU HAVE TOO! (At least that's how it seems upon relaunching Neo4j Desktop). Don't be like me and just delete stuff willy nilly in a moment of frustration. This problem definitely needs a solution, though.

Maybe that can be true @whalsey but in our case we are using desktop app just to connect to our remote neo4j server so should not be a problem 🙂

I can be wrong but my gut feeling says it should not delete local neo4j data as it's just configurations for UI app, data folder for neo4j database is actually in separate folder.

But yeah I agree it needs to be taken care.

Node Link

This the way I got workaround this issue on my Windows 10. I went to C:\Users\myUser\AppData\Roaming\Neo4j Desktop and deleted the Cache folder.
I run the Movies app and clicked on the Open Browser button which is 1.1.17 release. I got the browser is damage message and at the same time, a pop up suggested me to change the default ports to 11004 for bolt, 11005 for HTTP, and 11006 for https. I suggest that in case the pop up does not appear, change the ports manually. In the Notification Center, I was suggested to update the browser form 1.1.17 to 1.1.18 release. I accepted and the new version was installed successfully. And now all is running ok. So I guess the issue is the default ports that do the application crash. I hope this helps.

Thanks for that. I'll give it a shot.

I have four graph databases and in relation to the browser only one keeps the default ports, in the other three cases the ports have changed

Node Link

We just released Neo4j Desktop 1.1.18 which, amongst other things, fixes this issue.
Please upgrade and neo4j-browser should work again.

Thanks för reporting this in the first place.

When you say "just" do you mean today 28 March 2019? If so, I'll try it again, after redownloading it last night, exiting, and then getting the Damaged message this afternoon.

I just tried to download Neo4j again, but it's still v.17.

Where do I find v.18, please?

Yeah, earlier today so you missed it by a few hours
You can get the update from the sidebar of your current installation.
You should see a green indicator on one of the tabs in the sidebar.

Ok. It looks like it's working - at least I don't get the Damaged message anymore, and it's v18. Holding thumbs. Thanks Oscar.

Node Clone

Problem is back again..i deleted my old version from the folder, but now it's back again..i delete and it come back over and over to fix???

I'm using the new version 1.1.18..the browser is 3.2.14. I have 2 versions of the browser in my graph aps folder 3.2.14 and 3.2.18. I delete the 3.2.14...but it comes back after a message 'can't load the licence' Any help would be great!

This works for me!!!!!!!!!!!!!!!!!!

I am getting same error after I just updated the neo4j desktop v3.2.17 on Mac. It is as useful as paperweight now.
To be clear, v3.2.17 is the Neo4j Browser app.
Neo4j Desktop is Version 1.2.1 (
The error is "Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.


Hello, I have this very problem with the latest installation (browser v 4.0.2). So I have tried to install the browser app from the following URL ( This installed a new browser v4.0.2 alongside the broken one. While the new one works and I can now run new queries etc., I need to rescue my saved scripts from the original browser somehow. Does anyone know where they are stored and how to get at them?

I'm running Neo4J on Mac)S Mojave v10.14.6

Thanks in advance

What exact problem do you have with browser?

And it would be best to report that error on the browser GH repo for the eng-team.

Anything in the JS console (you can switch desktop to "development mode" in the setting which gives each graph app an "developer tools" button.

Hello Michael, thanks for replying.

The error is the same as the top of this thread: "Graph App 'Neo4j Browser' is damaged and can't be opened. Please re-install the app.". This happened after allowing Neo4j to do an update. However, I can't find any obvious way to reinstall the app, only to install a version alongside it (following the method suggested in this trail). The second installation clearly works - I can run queries etc. fine. However, I had an extensive set of saved scripts that aren't available to the second installation (not sure if they would survive reinstallation of the first instance??), so I'm trying to see if I can grab those files and safeguard them or import into the second instance, if that makes sense?

I'll try debug mode and see if I can spot anything amiss to report as you suggest.

The error I found in the console:
Desktop.1e4412d522aa830c231e.bundle.js:141 [11:45:32:0019] Graph-App 'Neo4j Browser' execution blocked: signature verification failure. Error: Error: Invalid content digest.
at Object. (/Applications/Neo4j
at ()
at fulfilled (/Applications/Neo4j
at process._tickCallback (internal/process/next_tick.js:68:7)