cancel
Showing results for 
Search instead for 
Did you mean: 

Error running docker after adding gds to plugins

jlavin
Node

Hello - I am trying to add gds to the dockerhub image of Neo4j and running into the following error when trying to just run "RETURN gds.version()":


ERROR Client triggered an unexpected error [Neo.DatabaseError.General.UnknownError]: 'scala.Function1 org.neo4j.cypher.internal.ast.semantics.SemanticPatternCheck$.checkValidPropertyKeyNamesInReturnItems(org.neo4j.cypher.internal.ast.ReturnItems)', reference 5de785c9-4bf7-471c-9449-5ae6717ae99d.

I am running the docker image: neo4j:4.4-enterprise

I've tried both the GDS 2.1.9 and 1.8.8 versions of the library to no avail. 

I have also added version 4.4.9 of cypher-shell to the plugins.

Is there a known working version of these three that would be better?  I thought by getting latest of each, I would be in a working state.

1 REPLY 1

jlavin
Node

After some more trial and error, I was able to get the neo 4.2-enterprise docker image to run with GDS 1.8.8 and cypher-shell 4.3.15.  Would love to use the later versions, but looks like there's some conflicts