Showing results for 
Search instead for 
Did you mean: 

Error: Neo.ClientError.Statement.ExternalResourceFailed

Node Clone

Hello guys,
I have an issue to my Neo4j-Desktop-Version.
I am trying to load some data from csv-files with the query:
[ load csv with headers from 'file:///Adresse.csv' as row merge ....]
and I got the Error-Message:
[ Couldn't load the external resource at: file:/C:/.../Data/dbmss/dbms-6511ab10-5cf0-4410-9dfb-39f38e329978/import/Adresse.csv ]
The path to my csv-file is right and my csv-file is also in the import-order.
In the neo4j.conf -file I have the line dbms.directories.import=import activated.
My NEO4J_HOME variable is also on the path:
[ C:/.../Data/dbmss/dbms-6511ab10-5cf0-4410-9dfb-39f38e329978 ]
I dont know what to do next ... Maybe some folder-right checks ?!?


It seems like the problem is not with accessing the file, but what is in the file? What kind of data is in the file? Is it comma separated strings or numbers?


View solution in original post


Did you select a non-default location for your application data?

The paths should be full paths and not relative (that is, is the ... in your Neo4j_HOME value?


My exactly NEO4J_HOME-Path is absolute, so: C:\Users\dioni\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-6511ab10-5cf0-4410-9dfb-39f38e329978 What exactly do you mean with application data? My .Neo4jDesktop folder?

Can you send the complete Cypher statement you are trying to execute?


Node Clone

My statement is:
load csv with headers from 'file:///Adresse.csv' as row merge (adr:Adresse {aid:apoc.create.uuid()}) on create set adr.ort= row.ort, adr.plz = toInteger(row.plz), adr.hausnummer= row.hausnummer, adr.strasse = row.strasse;
The columns ort, plz, hausnummer, strasse exists in my csv-file Adresse.csv, but I dont get it, why I am getting this Error.

What do you see when you execute:

load csv with headers from 'file:///Adresse.csv' as row
return row.ort, row.plz, row.hausnummer, row.strasse limit 3

Can you provide a screen shot of what you see in either cypher-shell or Neo4j Browser. We need to first figure out why you cannot access the file. Is the file spelled exactly as you have it here?


Node Clone

I got the same Error-Message. Yes the file-Name is correct and in my import-folder.

It seems like the problem is not with accessing the file, but what is in the file? What kind of data is in the file? Is it comma separated strings or numbers?


Ok, I got the problem. My csv-file was wrong formated. Very unlucky... Thank you.

I have also have same problem. Where do you find "neo4j.conf" file and how to find whether the csv file is wrongly formatted


What could I do if, in the same situation, the NEO4J_HOME-Path given by the error statement is different from the effective one?

This is the error statement:
Couldn't load the external resource at: file:/C:/Users/Utente/Documents/0.%20Programmi/0.0.Neo4J/relate-data/dbmss/dbms-76b32cbd-05b8-41d9-b9a6-57d243e8efc6/import/a_us.csv

And this is the effective path:
/C:/Users/Utente/Documents/0. Programmi/0.0.Neo4J/relate-data/dbmss/dbms-76b32cbd-05b8-41d9-b9a6-57d243e8efc6/import/a_us.csv

Node Link

Hi All. I have a slightly different problem on the same topic. I have already updated the conf file to allow import from custom folders and to allow import from file urls. With that, I am able to upload the csv file from a custom local drive (CSV load followed by a RETURN gives right results).

//this works perfectly...
LOAD CSV FROM "file:///D:/myfiles/neo4j/data.csv" as csvdata
RETURN csvdata

But when I am trying to access the csv file from a sharepoint folder (so that others can also update the csv), it is failing with the same ExternalResourceFailed error. this is how my code looks -

LOAD CSV FROM " with everyone/data.csv" as csvdata
RETURN csvdata

I have also tried

LOAD CSV FROM "" as csvdata
RETURN csvdata

just in case the spaces in the url were a problem but ended up with same result.
I even tried the public file - but wasnt able to import that either (I was able to download this csv directly from the browser). Anything that I am missing or any pointers on how to get to the root cause?

I was able to solve this problem. Opened the sharepoint location in windows explorer. Then right clicked on the file and got the windows path for the file. Used that with file:/// in the load csv and it worked.