cancel
Showing results for 
Search instead for 
Did you mean: 

Deep Install Links not working

jensboehm
Node

Hi all,

deep install links in the form neo4j-desktop://graphapps/install?url=... do not seem to work in Desktop 1.3.4. The Install buttons on https://install.graphapp.io/ do nothing, neither in the browser nor when I open the Graph App Gallery in Desktop itself.
Is this a known issue? I couldn't find anything about it. Help would be appreciated, since this also affects our own graph app. This used to work in the past. Thanks!

6 REPLIES 6

Joel
Ninja
Ninja

I'd like to hear more about this as well. I recall being able to click and install at some point, but have lately needed to copy/paste.

I believe it must be a known issue, due to the notes at the bottom of the graphapp.io page, it would be interesting to know what is causing it.


Which operating system are you using? I know that it doesn't work for me on Ubuntu, but I think the deep install links do work on Windows and Mac

(unless you tell me that you're using one of those...!)

I'm on Windows here.

Joel
Ninja
Ninja

TLDR; working for me on macOS

After running tests I have to wonder if OS or the browser could have settings (disable/block/deny, etc) which could prevent deep links from working? Accidentally or on purpose..

I'm multi-OS I'll post results separately.

Using the Install button on install.graphapp.io is currently working for both Chrome and Safari on the latest Neo4j desktop 1.3.4.27 on latest macOS Catalina Version 10.15.6 (to my surprise!?, I'll keep an eye on this...)

Test notes below

Chrome browser (my default)
2X_f_f1dc7a7e463612a5ecb6da6da10603520293fdf7.png

Safari (built in)


and I think I instinctively clicked though another message something like "would you like to always do this?", before I could catch it.

Joel
Ninja
Ninja

TLDR; Does not work for me on Windows 10
Note: in all cases the popup window dismisses, then nothing

Test notes: (java version ""1.8.0_251-b08)
Recently installed Windows 10 Pro (Version 2004 OS build 19041.450) which has never had Neo4j on it (a new computer), and I usually dual boot into Ubuntu, so perhaps a near ideal test situation.

Chrome - popup window "Open Neo4j Desktop?" click on "Open Neo4j Desktop" nothing happens
2X_4_4f4ba3897ea22b75169fc315f8966121a07fb9b3.png
internet explorer - popup window "Do you want to allow this website to open a program on your computer?", click Allow, then nothing happens
2X_d_de39cdf96ee8b4422c26ef47d75ed97c082f50af.png
edge - popup window "Did you mean to switch apps?" Click Yes, nothing happens
2X_3_32744c46d10db109e5aa5c68e9aad92bf005197c.png

Joel
Ninja
Ninja

TLDR; Does not work for me on Ubuntu 20.04 LTS
firefox (built in) - nothing happens
chrome - popup window, click allow then nothing happens

Test notes
I installed a fresh Ubuntu 20.04 LTS VM just to test (I use Ubuntu 20.04 LTS as my primary, currently, but it is complicated by multiple java versions, etc)

I see this popup
2X_1_1a5016950bd1bc87738bfb5058c2f87051dc8c65.png

Just to check, on the second try I clicked the "Always allow" checkbox, and as expected Chrome starts to behave like Firefox, then nothing happens in Chrome too when the Install button is clicked.