cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Pause, resolving how to handle anonymous content

Database failed to start: DB 'v4.1.3'. Multiple components failed to initialize the system graph

jeremyKer
Node

Hi,
I just installed neo4j on a Debian 9 server and tried to run movie database but it gives error. Version is 4.1.3
I could not understand what is wrong from logs.

2020-11-04 17:51:26.907+0000 INFO Starting...
2020-11-04 17:51:29.079+0000 INFO ======== Neo4j 4.1.3 ========
2020-11-04 17:51:36.481+0000 ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address. Error starting Neo4j database server at /usr/share/neo4j/data/databases
java.lang.RuntimeException: Error starting Neo4j database server at /usr/share/neo4j/data/databases
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.startDatabaseServer(DatabaseManagementServiceFactory.java:198)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.build(DatabaseManagementServiceFactory.java:158)
at org.neo4j.server.CommunityBootstrapper.createNeo(CommunityBootstrapper.java:36)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:117)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:87)
at org.neo4j.server.CommunityEntryPoint.main(CommunityEntryPoint.java:35)
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.dbms.database.DefaultSystemGraphInitializer@2a3194c6' was successfully initialized, but failed to start. Please see the attached cause exception "Multiple components failed to initialize the system graph:
multi-database: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.
security-users: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.".
at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:463)
at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:110)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.startDatabaseServer(DatabaseManagementServiceFactory.java:189)
... 5 more
Caused by: java.lang.IllegalStateException: Multiple components failed to initialize the system graph:
multi-database: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.
security-users: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.
at org.neo4j.dbms.database.SystemGraphComponents.initializeSystemGraph(SystemGraphComponents.java:99)
at org.neo4j.dbms.database.DefaultSystemGraphInitializer.initializeSystemGraph(DefaultSystemGraphInitializer.java:41)
at org.neo4j.dbms.database.SystemGraphInitializer.start(SystemGraphInitializer.java:29)
at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:442)
... 7 more
2020-11-04 17:51:36.488+0000 INFO Neo4j Server shutdown initiated by request

Any ideas about what the problem could be? Am I doing something wrong in this?
Thanks!

12 REPLIES 12

roberto1
Graph Buddy

could you share the conf file?

I rename the file and change the extension to upload it
neo4j-conf.txt (38.9 KB)

ok, could you change in the conf file the network connector configuration.

# Bolt connector
dbms.connector.bolt.enabled=true
#dbms.connector.bolt.tls_level=DISABLED
#dbms.connector.bolt.listen_address=:7687

# HTTP Connector. There can be zero or one HTTP connectors.
dbms.connector.http.enabled=true
#dbms.connector.http.listen_address=:7474

# HTTPS Connector. There can be zero or one HTTPS connectors.
dbms.connector.https.enabled=false
#dbms.connector.https.listen_address=:7473

Hello @roberto1 , Thanks for your reply. I have changed the the config but i have always the same issue.

this line ERROR Failed to start Neo4j on dbms.connector.http.listen_address still appearing?

Yes, always

2020-11-04 20:17:17.348+0000 INFO Starting...
2020-11-04 20:17:19.578+0000 INFO ======== Neo4j 4.1.3 ========
2020-11-04 20:17:26.975+0000 ERROR Failed to start Neo4j on dbms.connector.http.listen_address, a socket address. If missing port or hostname it is acquired from dbms.default_listen_address. Error starting Neo4j database server at /usr/share/neo4j/data/databases
java.lang.RuntimeException: Error starting Neo4j database server at /usr/share/neo4j/data/databases
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.startDatabaseServer(DatabaseManagementServiceFactory.java:198)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.build(DatabaseManagementServiceFactory.java:158)
at org.neo4j.server.CommunityBootstrapper.createNeo(CommunityBootstrapper.java:36)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:117)
at org.neo4j.server.NeoBootstrapper.start(NeoBootstrapper.java:87)
at org.neo4j.server.CommunityEntryPoint.main(CommunityEntryPoint.java:35)
Caused by: org.neo4j.kernel.lifecycle.LifecycleException: Component 'org.neo4j.dbms.database.DefaultSystemGraphInitializer@2819c460' was successfully initialized, but failed to start. Please see the attached cause exception "Multiple components failed to initialize the system graph:
multi-database: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.
security-users: org.neo4j.graphdb.DatabaseShutdownException: This database is shutdown.".
at org.neo4j.kernel.lifecycle.LifeSupport$LifecycleInstance.start(LifeSupport.java:463)
at org.neo4j.kernel.lifecycle.LifeSupport.start(LifeSupport.java:110)
at org.neo4j.graphdb.facade.DatabaseManagementServiceFactory.startDatabaseServer(DatabaseManagementServiceFactory.java:189)
... 5 more

roberto1
Graph Buddy

It is about the JDK. If you add your DB settings this line, it will be solved.

Configuration:
dbms.jvm.additional= -Duser.country=EN -Duser.language=EN -Duser.variant=Traditional_WIN

i tried this afternoon and i had the same issue.
I retry again but it's the same

that's weird, let me think what else could be

roberto1
Graph Buddy

could you comment this line?
#********************************************************************

Other Neo4j system properties

#********************************************************************
dbms.jvm.additional=-Dunsupported.dbms.udc.source=desktop

Same result
Thanks again for your help

roberto1
Graph Buddy

if you create a new DB shows the same issue?