cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Database failed to create: Error: Could not change password

I Installed Neo4j Desktop 1.1.15 but can't create a local graph, need help please

14 REPLIES 14

paul_thomas
Node Clone

The fix suggested by Joe Huffman 10 days to create a server folder worked for me last week on the latest version of Neo4j desktop.

One of the Neo4j staff probably needs to comment on the issue / real fix but that work-around worked for me!

Thanks Paul

biYTccKCiu
Node Clone

That server folder ‘fix’ works for me too.

sceurpien
Node

I had the same issue, and I wrote a simple article how you can manage to start Neo4j on a Win10 computer.

I hope it helps.

The server folder fix is not working for mine. Is there any other method that I can try?

When you install Neo4j Desktop on Windows, it asks you whether you want it for a particular user or for all users. The best solution is to allow all users access to it.

Typically this problem is due to not having permission to write the the database folder. Did you specify a different folder for the application data when you installed Neo4j Desktop?

Elaine

I think I specified different folder for application data. Is there any way by which I can delete all the data files and re-install neo4j? I have it so far but I am still getting the same error and I am not able to understand as to why. The thing is even when I tried deleting all the previous Neo4J files, they do not get deleted.

Thanks Elaine, worked just fine for me.
Cheers, Matt

Do you have Admin privileges for your PC? If so, then I would:

  1. Uninstall Neo4j Desktop.
  2. Restart your system.
  3. Remove ALL files/folders that have neo4j in them (including hidden ones).
  4. Make sure you have an Internet connection.
  5. As Administrator, install Neo4j Desktop and let it install in the default location. During installation make sure you specify you want ALL users to have access to the application.
  6. If the installation completes successfully, you should be able to start Neo4j Desktop, create a project, and then create a graph. In that project, you should be able to install plugins/libraries, provided you have an Internet connection.

Elaine

wilsonmar
Node

I'm having the same issue, running Desktop 1.2.3 on Mac Mojave.
I'm trying different Java SDKs to see if that helps.
BTW there is this: https://stackoverflow.com/questions/49342422/neo4j-database-failed-to-create-error-could-not-change-...

If this is the only database for this project, I would also try removing the "auth" folder. This will enable you to start from scratch.

Elaine

rk_chendol
Node

I was facing the same problem on Mac. I just upgraded the java version from Java 8 to Java 11 and it solved the issue. I doubt ,even though the java is embedded inside the package ,still it has some dependency with the system Java.

I'm working in a locked-down environment. I want to "play" with Neo4J to evaluate it for a possible project. Neo4J desktop was installed by an Administrator. When I try and create a new d/b I get....

Database failed to create: Error: Could not change password

HOWEVER if a sys admin starts Neo4J desktop they face no issues. So it seems to be a permissions problem. I have write permissions on the d/b folder.

@derek.gliddon is this a Windows system?

If so, during installation one of the options is to install Desktop so that all users will have access. Is it possible that the admin did not select that option?

Elaine