cancel
Showing results for 
Search instead for 
Did you mean: 

Connect to remote graph

madiskou
Graph Buddy

Hello,

I have a neo4j community edition installed in my server and i have a neo4j desktop in my machine.
I want to connect from my client desktop to the remote graph on my server.
I change this 2 params:
dbms.connectors.default_listen_address=0.0.0.0
dbms.connectors.default_advertised_address=Ip address of the server

but i have this error

1 ACCEPTED SOLUTION

It was the firewall configuration

View solution in original post

8 REPLIES 8

julie_fisher
Node Clone

I usually just set up the remote connection using Neo4j Desktop. In My Projects click Add Graph, enter the Connect URL and change the Database Name to something descriptive.

madiskou
Graph Buddy

my graph is on a distant server i can't connect with localhost, and there is a configuration to do in the server side.

It was the firewall configuration

what exactly did you do to resolve the issue? -.-

I open the port of bolt/http in the distant server and it work

damn, I already tried that ... so my config is likely not right -.-
can you share yours? obviously without the specific IPs ...
I haven't been able to set ip up yet ...

in your iptables you configure to accept connexion from specefic port

-A INPUT -p tcp -m state --state NEW -m tcp --dport 7474 -m comment --comment " port http neo4j" -j ACCEPT

I have allowed the necessary ports. I have now disabled the firewall for testing purposes and will now start testing -.-

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.