cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Cannot use GDS library

cat971216
Node Link

Hi,

I am using Neo4j desktop (Version 1.4.12, Neo4j 4.4.3, ) and have installed GDS library plugin. I have followed the instructions from Neo4j Desktop - Neo4j Graph Data Science   and copied the two lines into the setting of my database. But when I want to use functions such as  CALL gds.graph.project.cypher, it still returned 

There is no procedure with the name `gds.graph.project.cypher` registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.

I guess I did not install GDS library successfully. How can I deal with it?

Many thanks! 

1 ACCEPTED SOLUTION

That shows you have version 1.8 installed. Mine shows as 2.1. The following screenshot is from the 1.8 documentation. Looks like the ‘project’ methods were the ‘create’ methods in that earlier version. You can verify this by executing ‘show procedures’ in your desktop and review the gds procedures. 

I guess you can either use the old syntax or upgrade to the latest version of gds. 

9C761564-9CA2-4D42-BD0A-02118CE09616.png
1.8 docs;

https://neo4j.com/docs/graph-data-science/1.8/management-ops/graph-catalog-ops/

View solution in original post

10 REPLIES 10

glilienfield
Ninja
Ninja

what do you see when you the plugins tab for your database?  Here is a screenshot of a database of mine that has GDS installed.  Does yours look the same?

Screen Shot 2022-07-24 at 10.04.31 PM.png

Hi,

Thank you for your reply. I think it looks as your. 

cat971216_0-1658732588436.png

 

 

That shows you have version 1.8 installed. Mine shows as 2.1. The following screenshot is from the 1.8 documentation. Looks like the ‘project’ methods were the ‘create’ methods in that earlier version. You can verify this by executing ‘show procedures’ in your desktop and review the gds procedures. 

I guess you can either use the old syntax or upgrade to the latest version of gds. 

9C761564-9CA2-4D42-BD0A-02118CE09616.png
1.8 docs;

https://neo4j.com/docs/graph-data-science/1.8/management-ops/graph-catalog-ops/

Hi, 

Thank you very much for replying! I think this is the problem.

I'd like to upgrade the gds, but it only provides version 1.8 on my Neo4j desktop. How can I upgrade it? I tried to upgrade my Neo4j version from 4.3 to upper versions but failed. Is it possible if I install the plugin got from the download center to Neo4j desktop?

I have had upgrade fails before.  I recall one time fixing it by removing all plugins before upgrading it and it worked. You can reinstall the plugins after.  Maybe this will allow you to install the latest GDS too. 

You should be able to replace the GDS jar in the plugin folder, as long as the version is compatible with your neo4j version. 

I searched in my Neo4j installation folder and the only plugin file is "neo4j-plugin-0.1.1-all.jar". Seems I cannot replace GDS only but have to reinstall the whole Neo4j Desktop. But thank you anyway! 

That is a little strange.  Here is a screenshot of my plug-in folder, which shows the gds plug-in. Something seems out of sync. Can you uninstall each plugin and reinstall them after upgrading?

Screen Shot 2022-07-25 at 9.48.07 PM.png

Yes it's also strange to me. Here are my screenshots. I also don't have the README.txt there.

cat971216_0-1658868018822.png

cat971216_1-1658868072158.png

 

 

We have no plugins in common. You could try moving that plugin out of the folder, restarting the database, and see if you can install GDS from the database's 'plugin' tab.

Thank you for keep replying!

I tried as you said. Seems it does not affect anything. I uninstalled the software and reinstall with the most updated install package (and amazingly it still keeps all my databases). I still find the "neo4j-plugin-0.1.1-all.jar" file, and I find another one in below screenshot.

But the good news is after I reinstalled it, I can update the Neo4j version and get updated plugins. The bug may be related to 1.4.12 installation package I used.

Thank you so much for your help all the way!

cat971216_0-1658942179177.png