Showing results for 
Search instead for 
Did you mean: 


Dear all,

I struggle for weeks and I still have this problem:

Neo.ClientError.Procedure.ProcedureNotFound: There is no procedure with the name algo.list registered for this database instance. Please ensure you've spelled the procedure name correctly and that the procedure is properly deployed.

It seems like there is no graph algoritm plugin, but I am sure I correctly configurated my conf file and I tried different neo4j versions having the same result! I also read the thread here:

but I still have the same problem.. I don't know what is the possible issue!

I have Ubuntu 16.04 (64 bit) and I try to use tarball installation.
I tried the following configurations:

  • neo4j 3.4.10, algo, apoc
  • neo4j 3.5.12, algo, apoc
    PS I have no problem with apoc

Thanks in advance!!!



using a 3.5.12 Neo4j install and from a tar kit, and with neo4j-enterprise-3.5.12/plugins defined as

 ls -al ../plugins/
total 14868
drwxr-xr-x  2 neo4j neo4j     4096 Nov 12 17:13 .
drwxr-xr-x 12 neo4j neo4j     4096 Nov 12 17:14 ..
-rw-rw-r--  1 neo4j neo4j 13749813 Sep  5 11:54 apoc-
-rw-rw-r--  1 neo4j neo4j  1459334 Jul 15 15:00 graph-algorithms-algo-

and with conf/neo4j.conf including

 tail ../conf/neo4j.conf

# Name of the service

# Other Neo4j system properties

and finally

lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.2 LTS
Release:        18.04
Codename:       bionic

after running bin/neo4j start I can then run via bin/cypher-shell

Connected to Neo4j 3.5.12 at bolt://localhost:7687 as user neo4j.
Type :help for a list of available commands or :exit to exit the shell.
Note that Cypher queries must end with a semicolon.
neo4j> call algo.list() yield name;
| name                                         |
| ""               |
| "algo.articleRank"                           |
| ""                    |
| "algo.asPath"                                |
| "algo.balancedTriads"                        |

so it works for me 😞 and this appears to be a similar setup to yours, albeit I am running Ubuntu 18. I wouldnt expect that the OS should be causing yours not to work. Can you check the size and file permissions of plugins/ ? Are they similar to mine? Does your logs/debug.log report any errors?