Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 1: replicate users.

Can't handle this error anymore


Hi there

I'm starting to be frustrated by this non sense error

Desktop version
Neo4j Desktop 1.4.12
When it happens
I just try to uncheck the encrypted connection checkbox from my remote database settings and even this simple local action doesn't work anymore in the desktop.

Unable to establish remote connection: Neo4jError: WebSocket connection failure. Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. Please use your browsers development console to determine the root cause of the failure. Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket readyState is: 3

Any light about it?



How are you using Browser? In a web browser, launched, as a graphapp, or something else?

See the SSL section of this other topic:

I suspect what's happening is that your web browser is loading Neo4j Browser over HTTPS. You are then saying "make an unencrypted connection" and your web browser is blocking that, because the page (Neo4j browser) is secure, and attempting to make an insecure/unencrypted connection from within a secure page. This is what I'd look into. It's been a while since I saw this, but different browsers (Chrome & Firefox, etc) respond differently when you try to do this (make an unencrypted connection from an encrypted origin)

All of this started when I tried to simply update bloom from 1.9 to 2 by changing the .jar file in the plugins folder, then I just restarted by Neo4j instance and boom!

Indeed, at first, my Neo4j was using an encrypted connection with an SSL certificate genereted by cerbot.

Even then, I was getting this error message so I disabled it from the server, I did double checked

1 - I make sure that the service was online with systemctl status neo4j
2 - I checked that dbms.connector.bolt.tls_level=DISABLED in .conf after the service was started
3- I double check my public IP address and firewall rules in my Google Compute Engine VM

Then I tried to switch from encrypted connection to an unencrypted on but the desktop didn't let me do it showing this use error just because i was trying to uncheck a checkbox.

I think the reason why it does this it's because Neo4j desktop check the state of the encrypted connection just one time when you create it with the URL provided. But to be honest I hope one day SSL will be gone it's just a bunch of problem this thing.

Emails have much better and easier encryption structure using records in the domain name without an "certificate".