cancel
Showing results forΒ 
Search instead forΒ 
Did you mean:Β 

Can't access Neo4j community version installed on a Linux virtual machine in Azure

LJRB
Graph Buddy

I have to install Neo4j community edition on a VM in Azure I can't access in the browser.

I did this:

  1. Created a virtual machine in Azure on which you can host a Neo4j community version server
    I choose Linux (Ubuntu 18.04) virtual machine in Azure
  2. Connect to the virtual machine throught Azure CLI and start installing
  3. Installed Java 11
  4. Installed the latest Neo4j community version
  5. Setted up Neo4j to be accessible over the internet: sudo vim /etc/neo4j/neo4j.conf
  6. Add/edit the following lines to the config file:
dbms.connector.bolt.enabled=true
dbms.connector.bolt.listen_address=0.0.0.0:7687
dbms.connector.http.enabled=true
dbms.connector.http.listen_address=0.0.0.0:7474
  1. To access port 7474 from outside the Linux machine, I added it to the inbound port rules for the virtual machine (but I'm not sure if I did it wright)

  1. I tried to access to Neo4j in the browser with: http://<ip_adress_of_vm>:7474

But 😎 doesn't work: ERR_CONNECTION_REFUSED.
I don't know if it is the best method to install Neo4j community version in a Linux virtual machine.

What do I have to change to succeed in opening this in the browser ? Maybe I did bad 7) ?

3 REPLIES 3

LJRB
Graph Buddy

I found the solution, I had to add port 7474 and 7687 to inbound security rules. And it works

Instead of Ubuntu, I have used Red Hat Enterprise Edition 8.1 also enabled both the port, But I am unable to browse using Browser with 7474 port.

Can someone help me in it

in your conf/neo4j.conf have u enabled remote browser connections similar to


#*****************************************************************
# Network connector configuration
#*****************************************************************

# With default configuration Neo4j only accepts local connections.
# To accept non-local connections, uncomment this line:
dbms.default_listen_address=0.0.0.0