Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 1: replicate users.

Browser and Shell Show Different Databases Via Remote Server

Node Clone

I've been using Neo4j (4.4.4) for a while via a remote server (ubuntu 20.04 ) with no problems. I decided to reinstall Neo4j due to a problem I had, but this resulted in a series of bigger problems.

Firstly, I uninstalled Neo4j with (sudo apt-get purge neo4j), but the data was still available after installing a newer version of Neo4j (4.4.9). This made me realize that the previous command does not delete everything. I had a problem with neo4j.service status being FAILED. I decided to uninstall again and remove everything this time. I used the previous command followed by 

sudo rm -r /var/lib/neo4j/*

sudo rmdir /var/lib/neo4j/

Then I deleted the configuration file (neo4j.conf) at etc/neo4j

I installed neo4j (4.4.5) and it worked with no problems. However, the previous data was still there! When I tried to access cypher-shell I was asked to set a new password. Then I noticed that the browser database has version 4.4.9, while the one I access with the shell has version 4.4.5. When I try to access the most recent database (version 4.4.5) on the browser through bolt connection I get this error message (Neo.ClientError.Security.Unauthorized: The client is unauthorized due to authentication failure.)

How can I make the shell and browser databases consistent? Should I do a clean uninstallation? How? I am also baffled by the presence of the old data even though I deleted the neo4j directory in /var/lib/ which contains the data file!



Perhaps you have a 2nd installation somehow on that machine?

What do the log files in /var/log/neo4j say? 

Also make sure to not confuse neo4j browser version with the db version.

You can also check the processes running and see if there is another installation in a different folder

ps auxwww | grep neo4j

After writing my post, I decided to locate all files related to neo4j by using this as a refenence. I then uninstalled neo4j and used sudo apt autoremove. I reinstalled the 4.4.9 version and enabled the service. Now when I run ps auxwww | grep neo4j, I think I have multiple processes running. I'm not sure if it's safe to share the exact output, but I get something like this:

neo4j     #  0.0  0.2 # #; where # is some number. 

There is another one with different numbers.

Then there is:

ubuntu    #  0.0  0.0  #  #

root     #  2.5 22.1 # #

I guess this means I have multiple processes running. How can I stop them safely?Should I kill them all then reinstall neo4j again?