cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Bloom broken after amending Perspective

michela
Node Clone

I've been happily using Bloom for ages but today I added a new node label to a local graph in Neo4J Desktop, tried adding the new label to the Perspective created in Bloom by default - and now can no longer use Bloom.

Using Neo4j Desktop 1.2.5, Bloom 1.2.1

Repro:

  • Create local db
  • Open Bloom, accept default Perspective
  • Add additional node label via Cypher
  • In Bloom, add new Category (it appears but does not appear to be selectable - is not added to list - just appears as predictive text in add label dialogue)
  • Restart database and Bloom - now Bloom shows flower animation then white screen with top menu bar.
  • Bloom | Developer | Reload - same

Any advice? Where are Bloom Perspectives saved?

I've deleted C:\Users*****\AppData\Roaming\Neo4j Desktop\Cache but can't find where relationships are saved - in case this is what is corrupted

And BTW where is the Bloom issues github now? It was good to be able to submit bugs and enhancement issues via github

UPDATE - copying database to another machine I was able to get Bloom working again and amend the Perspective to add the new Category. Would like to be able to fix original PC though.

1 REPLY 1

markengelstad
Node Link

This just happened to me in the exact causal sequence you outlined.
It was adding a new Category that triggers Bloom into showing a white screen only.
Neo4j Desktop : Version 1.2.5 (1.2.5.1637)
Bloom: 1.2.1

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit - November 16 - 17, 2022.


Free NODES Training Series


October 19th -

Intro to Neo4j


October 20th -

Healthcare Analytics Using Neo4j


October 25th -

Handling Neo4j data with Apache Hop


October 26th -

Blazing Fast Graphs: Hands-on with Apache Arrow and Neo4j


November 2nd -

Graph EDA Using the Neo4j GDS Client