Showing results for 
Search instead for 
Did you mean: 

Basic Cypher condundrums


I am not a programmer and I've just started playing with this and have some, what I am sure, are basic problems

I've created a really basic graph
some of the nodes show the name and some don't and I can't work out why. I did go through and put a name property on all the nodes as it seemed to work on some but it's still not working on all
These ones show their node 'name' on the graph
CREATE (XXX19:UserStory {name:'XXX-19', priority:'Low', Description:'As an Android system', Estimate:'Unestimated', Status:'To Do', created:150419})
CREATE (Tamas:Assignee { name:’Tamas’})
as does this, even though it doesn't have a property 'name', it displays 'version'
CREATE (V10:Version {version:'V1.0'})
but this one shows no text on the node at all
CREATE (F0093:Epic {name:'F-0093', priority:'Low', Name:"Services and applications", Status:'To Do'})
and this show the
CREATE (Backend:Label { name:’Backend’})

Why are some showing the name in the graph and others not? I've been messing around with this for a couple of days now to no avail



I assume that you are using Neo4j Browser.

Neo4j Browser, when it visualizes a graph for display it uses a single property for all nodes with the same label.

I am not sure why the node of type Epic is not showing the name property in the display. Is it possible that you created other Epic nodes earlier and used a different property and subsequent nodes do not use this property?

In the Neo4j Browser graph display, you can select a label at the top and then select what property you want to represent the node in the display.


Graph Steward

Are you talking about when you visualize the graph in Neo4j desktop? You'll find that some nodes don't show text but when you click on them that their properties will be displayed below them

As to why some nodes show their properties and others don't I'm not exactly sure why. However you should always be able to see the contents of a node if you click on the table icon:

In my own efforts to recreate what you seem to be experiencing this is what I got:

It might help if you included some screen shots of your own or gave us an overview of exactly what you're trying to accomplish.

Graph Voyager

Hey Sara,
Here is what I'm seeing on a default empty graph.

I've had some nodes not show a caption before as well.To fix this as mentioned by @elaine.rosenberg

  1. Select the label that isn't showing it's caption.
  2. Expand the panel with the arrow on the right and select the property you want to display.
    2b. You may also want to try resizing the nodes to make them larger. I had a case where it wasn't showing up because the circle was to small.

    EDIT: looks like the drop down arrow to the right of "Size" got cut off the screen clip.
    Hope that helps, if not let us know.



YES! Mike that worked an absolute treat!
thanks Michael, looks like we were getting the same results, the way to select what is displayed as described by Mike worked beautifully.
sorry for the delay in responding, work went nuts and I didn't get a chance to have a look at it until today