cancel
Showing results for 
Search instead for 
Did you mean: 

APOC NLP (Amazon) error due to "the trustAnchors parameter must be non-empty"

grahamcn
Node Link

hello all,
having downloaded the APOC NLP plugin (apoc-nlp-dependencies-4.0.0.12) into a Community 4.04 instance, I've had no issues using the apoc.nlp.aws.* procedure on my local MacBook, works wonderfully.

When repeating the process on a Community AMI on an EC2 instance, I get the error:

Failed to invoke procedure apoc.nlp.aws.keyPhrases.stream: Caused by: java.security.InvalidAlgorithmParameterException: the trustAnchors parameter must be non-empty

I've been on something of a stack overflow trawl and found Ubuntu Java versions possibly causing this issue, but i wanted to ask first if this is possibly due the EC2 server not having SSL set up?

I'm keen to avoid configuring Java - or changing versions, say - as it's not something I know (Java, nor am I a Linux/OS person), nor do i know how else this would impact the AMI set up - hence the use of a preconfigured AMI.

Any thoughts would be much appreciated
Graham

1 ACCEPTED SOLUTION

I ended up finding time today to rebuild my instance from the new 4.1.0 AMI. This came with apoc-4.1.0.0-all.jar preinstalled.
I then manually added the NLP 4.1.0.1 from the APOC 4.1.0.1 release, and also updated the APOC jar.
I am also using the Data Science 1.3.0.
All working fine together, entities being extracted - thanks again for the input, it nudged me to updating all to latest 🙂

View solution in original post

6 REPLIES 6

webtic
Graph Fellow

Hi Graham, welcome to the community.
I noticed there is a new release for the nlp-dependencies.
https://github.com/neo4j-contrib/neo4j-apoc-procedures/releases/download/4.0.0.17/apoc-nlp-dependenc...

Could you give that one a try?

Hi Paul - thanks for the suggestion and the welcome, I will try this over the weekend.
I'm on 4.0.4 of community, and there is a 4.0.5 available (soon 4.1.1 too I guess) so can also perhaps try updating to that version on the Ubuntu AMIs with the latest NLP, but no issues on my local (MacBook) instance with 4.04 and NLP 4.0.0.12.
Thanks again,
Graham

It might be an issue related to the SSL/TLS certifications on each environment.

Recently I had similar issues with different behaviour on Ubuntu and macOS in a Python script which aborted due to this.

You might want to try to do

update-ca-certificates

on the Ubuntu install and see if that helps.

I did see mention of that in my search, I'll read up a little more & add it to the list of things to try

I ended up finding time today to rebuild my instance from the new 4.1.0 AMI. This came with apoc-4.1.0.0-all.jar preinstalled.
I then manually added the NLP 4.1.0.1 from the APOC 4.1.0.1 release, and also updated the APOC jar.
I am also using the Data Science 1.3.0.
All working fine together, entities being extracted - thanks again for the input, it nudged me to updating all to latest 🙂

Great to hear its all ok now, tracking latest is a good idea 😉

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.