cancel
Showing results for 
Search instead for 
Did you mean: 

APOC Incompatibility working when truing to use apoc 4.4.0.4 and neo4j 4.4.7

melonman
Neo4j
Neo4j

Hi Experts!

I downloaded the tar version of the neo4j 4.4.7 and installed it to Linux and Mac, moved the apoc .jar in labs to plugins. (I think this is pretty straight forward as an initial setup..)

When I looked at neo4j.log, I found the following entiry:

2022-06-09 00:57:04.718+0000 WARN [neo4j/ebad71c5] The apoc version (4.4.0.4) 
and the Neo4j DBMS versions [4.4.7] are incompatible.

Does anyone know where to look for about this message?
Any comment would be appreciated!

Thank you!

2 REPLIES 2

glilienfield
Ninja
Ninja

I have neo4j 4.4.7 running locally and using Neo4j browser. The apoc plugin installed is 4.4.0.5. It states "compatible version 4.4.0.5." 

Screen Shot 2022-06-10 at 7.43.14 PM.png

Thank you for the info 🙂

after reading this, I moved 4.4.0.5 to plugin directory, but still see this.

2022-06-11 00:04:48.170+0000 WARN  [neo4j/ebad71c5] The apoc version (4.4.0.5) and the Neo4j DBMS versions [4.4.7] are incompatible.
See the compatibility matrix in https://neo4j.com/labs/apoc/4.4/installation/ to see the correct version
2022-06-11 00:04:48.800+0000 INFO  Remote interface available at http://localhost:7474/

ummm...