cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

4.4.9 Failed to ' apoc.import.graphml': set apoc.import.file.enabled=true

gennaria
Node

 

I'm working on: 

NAME="CentOS Linux" VERSION="7 (Core)" ID="centos" ID_LIKE="rhel fedora" VERSION_ID="7" PRETTY_NAME="CentOS Linux 7 (Core)"

I'm trying to import a graphml file, which is in the /var/lib/neo4j/import/ folder. 

in my neo4j.conf I have the following settings:
dbms.directories.import=/var/lib/neo4j/import
apoc.import.file.enabled=true
apoc.export.file.enabled=true

I created a new file apoc.conf, with the following lines:
apoc.import.file.enabled=true
apoc.trigger.enabled=true
apoc.import.file.use_neo4j_config=true

I also created a file neo4j.template, following some suggestion founded online, with:
apoc.trigger.enabled=true
apoc.import.file.use_neo4j_config=true

But I'm still getting the same error. Any suggestion?  

thanks

1 REPLY 1

Where did you put these? Did you restart the neo4j server?