cancel
Showing results for 
Search instead for 
Did you mean: 

Unable to execute APOC procedure on embedded graph database

nar_kendre
Node

Experts,
We are using the inventory application with an embedded graph database.

APOC plugin jar apoc-3.5.0.3-all.jar is deployed against the neo4j Release 3.5.5. It is working fine on default graph database.
If same is connected with Embedded Database on bolt protocol 7070, unable to execute the APOC

Similarly

APOC plugin jar apoc-3.4.0.4-all is deployed against the neo4j Release 3.4.18. It is working fine on default graph database.
If same is connected with Embedded mode on bolt protocol 7070, unable to execute the APOC.
Please help to analyse.

Thanks

1 REPLY 1

Why are you running embedded in the first place,
The APOC bit got much more tricky recently.

In general you have to provide the apoc jar in the classpath but then also configure the plugin directory for the procedure loader to pick it up.