cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site maintenance this Wednesday, February 1. Disruptions expected as we migrate the forums.

neo4j spark connector issue

fathima
Node

I am facing this issue

org.neo4j.driver.exceptions.ClientException: The server does not support any of the protocol versions supported by this driver. Ensure that you are using driver and server versions that are compatible with one another.

I am using a neo4j spark connector, ' neo4j-connector-apache-spark_2.11-4.0.2_for_spark_2.4.jar ' for reading data from neo4j. 

Scala version - 2.11

Spark - 2.4 

and Neo4j is 3.3.x

Why that issue is arising? 

I couldn't find any connectors matching the spark and scala versions. 

Thanks

 

1 REPLY 1

Cobra
Ninja
Ninja

Hello @fathima 🙂

I'm pretty sure your version of Neo4j is too old for this connector. You should upgrade Neo4j to the latest version possible (4.4). Version 3 of Neo4j is not maintained anymore and 4.1 will soon be too.

So upgrade both Neo4j and Neo4j Spark Connector to the latest version.

Some documentation:

Regards,
Cobra