Installation: rdf endpoint: "404 Not Found"

paltusplintus
Node Clone

Dear Community,

I am struggling with accessing rdf endpoint after setting up n10s on docker following instructions.
I run the docker (Neo4j 4.2.3) with the following string:

sudo docker run --env NEO4J_AUTH=neo4j/admin --restart always --publish=7473:7473 --publish=7474:7474 --publish=7687:7687 --volume=$HOME/neo4j/datans:/data --volume=$HOME/neo4j/pluginsns:/plugins --volume=$HOME/neo4j/logsns:/logs --name neo4j-ns -e NEO4JLABS_PLUGINS='["apoc", "n10s"]' neo4j &

after which the following plugins get successfully installed:
apoc-4.2.0.4-all.jar to /plugins/apoc.jar
neosemantics-4.2.0.1.jar to /plugins/n10s.jar

The n10s procedures are available when running

call dbms.procedures()

however

:GET http://<ip address>:7474/rdf/ping

returns

Do you have any ideas what might be going wrong here?
I also tried to add the following in the docker run string

-e NEO4J_dbms_unmanaged_extension_classes=n10s_endpoint=/rdf

but it did not help.

Thank you!
Alexey.

1 REPLY 1

paltusplintus
Node Clone

Solution found inspired by this post
My working docker run string is as follows:

sudo docker run \
--env NEO4J_AUTH=neo4j/admin \
--restart always \
--publish=7473:7473 \
--publish=7474:7474 \
--publish=7687:7687 \
--volume=$HOME/neo4j/datans:/data \
--volume=$HOME/neo4j/pluginsns:/plugins \
--volume=$HOME/neo4j/logsns:/logs \
--volume=$HOME/neo4j/rdf:/rdf \
--name neo4j-ns \
-e NEO4JLABS_PLUGINS='["apoc", "n10s"]' \
-e NEO4J_dbms_security_procedures_unrestricted=apoc.*,n10s.* \
-e NEO4J_dbms_security_procedures_whitelist=apoc.*,n10s.* \
-e NEO4J_dbms_unmanaged__extension__classes=n10s.endpoint=/rdf \
neo4j &