cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Connecting Postgre with Neo4j using ETL Tool

jaimeb
Node

I am trying to connect Neo4j with an existing database in Postgre using the ETL Tool but I don t know which information should i write in user and password. I keep getting this error:

 

nov 15, 2022 12:23:02 P.�M. org.postgresql.Driver connect
GRAVE: Connection error: 
org.postgresql.util.PSQLException: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
	at org.postgresql.core.v3.ConnectionFactoryImpl.doAuthentication(ConnectionFactoryImpl.java:614)
	at org.postgresql.core.v3.ConnectionFactoryImpl.openConnectionImpl(ConnectionFactoryImpl.java:222)
	at org.postgresql.core.ConnectionFactory.openConnection(ConnectionFactory.java:49)
	at org.postgresql.jdbc.PgConnection.<init>(PgConnection.java:194)
	at org.postgresql.Driver.makeConnection(Driver.java:431)
	at org.postgresql.Driver.connect(Driver.java:247)
	at java.sql/java.sql.DriverManager.getConnection(DriverManager.java:681)
	at java.sql/java.sql.DriverManager.getConnection(DriverManager.java:229)
	at org.neo4j.etl.rdbms.Support.testConnection(Support.java:32)
	at org.neo4j.etl.rdbms.Support.main(Support.java:74)

Connection failed. SQL state: 08004, message: The authentication type 10 is not supported. Check that you have configured the pg_hba.conf file to include the client's IP address or subnet, and that it is using an authentication scheme supported by the driver.
1 REPLY 1

steggy
Neo4j
Neo4j

@jaimeb The error is on the Postgres side. A quick Google of that error might set you in the right direction 🙂