Showing results for 
Search instead for 
Did you mean: 

Cannot upload .ttl file

Node Clone

I was really looking forward to getting a taste of the Linked Data world by attempting to load the Knowledge Graph Conference speaker set into Neo4j using Neosemantics However, even the first step of uploading a .ttl file does not work for me. Neosemantics does not see it as a .ttl file. I copied this text into a text file and saved it with a .ttl extension.
What am I missing? I even tried another set of text from the documentation, save it as a .ttl file, and it still is not recognized.
Appreciate any pointers of what I might be doing wrong. Thanks in advance.


Hi @Live_Data_Concepts, thanks for your interest in neosemantics.
The reason why n10s does not see the content in the url as RDF is because it's actually not RDF but the human-readable HTML version of the document as you see it in If you want to get the actual RDF you need to use the 'raw' version of the document (you can find it by clicking on the raw button on the page)

The following should work without issues:

call n10s.graphconfig.init();

call n10s.rdf.import.fetch("","Turtle")

Give it a try and let us know if that solved the problem.



Neosemantics manual.

Node Clone

Hi Jesus,
thanks for getting back to me so quickly. Your approach worked nicely to import the data into Neo4j. What I attempted to use is the Neosemantics app and load the data from a file. I downloaded the content and saved it as a file with .ttl as extension, and Neosematics app doesn't see such file. I don't understand why it wouldn't see such file? I must be missing something, no?
Here is the content of the file, at least the first snippet, which looks like turtle to me:
@prefix kgc: .
@prefix owl: .
@prefix rdf: .
@prefix rdfs: .
@prefix schema: .
@prefix skos: .
@prefix wd: .
@prefix xml: .
@prefix xsd: . a schema:Event ;
schema:eventAttendanceMode schema:OfflineEventAttendanceMode ;
schema:name "Knowledge Graph Conference 2019" ;
schema:superEvent ;
owl:sameAs wd:Q87486633 . a schema:Event ;
schema:about,,,,,, ;
schema:description "One of the challenges in protecting consumer privacy and managing data risk is the ability to validate that privacy-related data from across our data ecosystem has been identified and categorized accurately and consistently. This challenge has become especially salient in light of recent legislation like GDPR and CCPA. At Capital One, the 2nd line is using standardized semantic models (ontologies) and technology to validate whether data is privacy-related as well as recommend privacy categories to data producers." ;
schema:name "Validating Data Categories using Knowledge Graphs" ;
schema:performer, ;
schema:superEvent . a schema:Event ;

Thank you for your help. I am really excited about the Neosemantics app, as it might open the door to a lot of data that otherwise seem unaccessible to me.
Best, Wolfgang

I had the same problem. When I go to upload and try to use Turtle, I am not able to select any ".ttl" files. I tried Yago 1 dataset.

A possible workaround is to rename ".ttl" to ".txt". The app is then able to load it perfectly.

Another solution would be to use fetch command with the file's url. Here ".ttl" extension works fine.

CALL n10s.rdf.import.fetch(