Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Pause, resolving how to handle anonymous content

Sandbox in graphacademy apparently not working !


I'm having a difficult time trying to do the exercises along the course,

i disabled adblock but still not working

i get this error in the console "Uncaught (in promise) TypeError: Cannot read properties of undefined (reading 'code')"


Hello @b_othmane ,

Can you send the URL of the page where you are seeing the problem?

You might try signing out of GraphAcademy and then signing back in.


View solution in original post


Hello @b_othmane ,

Can you send the URL of the page where you are seeing the problem?

You might try signing out of GraphAcademy and then signing back in.


Nevermind, thanks it works now


Same here. Haven't had a successful execution yet. Tried signing out and back in. Also signed back in several times over the past two days with no change.

And its every CHALLENGE page I encounter that contains the sandbox.

I am not able to complete the lessons as Sandbox is not working for me either.  Ive tried on Chrome and MS Edge. Ive tried logging in and out and no change.  The sand box loads, I can write code, and when I try to execute it disappears and gives no return. 


Node Link

Sandbox is not working for

The integrated sandbox screen shows the prompt but isn't connected.

If I open my sandbox independently by going to My Account I see that it is up and running.  Unfortunately the database isn't setup that the tutorial expects.  


not working for me either. on my first challenge in cypher fundamentals.



Error fetching sandbox

Failed to fetch

I second this! I'm having that problem on that page as well. 😞


Hello, same issue today on and other pages.  I can run the Movie Sandbox from and that works fine.
I was able to use this to answer some of the previous questions in the course pages; but the above page wants to check the update to the specific sandbox on this page which doesn't load.
There I AM UNABLE TO PROCEED beyond this question 😞



I did the following:

  1. Signed out of GraphAcademy 
  2. Went to and Logged out
  3. Closed browser
  4. Went back to and logged back in and started the Movies project
  5. Returned to the GraphAcademy and Signed In
  6. Resumed the course
  7. The sandbox now starts successfully and the $neo4j prompt now appears

Hope this works for everyone else 🙂

Thanks!!! Finally can use the training sandbox features!

This worked, thanks!!

Thanks, was having the same problem and this basically worked for me. I wonder if it had to do with accepting the agreement when I first went to the sandbox url...


@elaine_rosenber I am still stuck in that state, even after logging out several times (also in the sandbox page) as suggested in the answer above.
I noticed that there is a loop of GET requests timing out (cf. attached screenshot).
This also applies to the sandbox page, where the pattern is the same.
Screenshot 2022-12-01 at 10.39.25.png

Hello @jannik,

There is feature in Firefox called Enhanced Tracking Protection that blocks sites. Can you temporarily disable it?


Thanks Elaine for the fast response. Unfortunatelly disabling Enhanced Tracking Protection and all ad blockers etc. does not change anything.


Remark: I found out that a sandbox is automatically being created for me and shown (including the credentials) under
visiting this sanbox directly (for me this is the link results in a similar behaviour (cf. attached screenshot)

Screenshot 2022-12-01 at 12.49.13.png

You might want to use Chrome as your Web browser to see if you still have the issue.

Thanks Elaine for the response. Unfortunatelly also using Chrome instead of Firefox (also without any ad blockers etc.) does not change anything.

Can you try chrome to see if the results are different?


I tried, but that did not change anything. I tried from a different network and that fixed the problem. Apparently some firewall configuration blocked the traffic to the sanbdox for some reason. Thanks for your support.

I've signed up to , refresh the course and everything works fine.