cancel
Showing results for 
Search instead for 
Did you mean: 

Sandbox doesn't work

20T40
Node

Tried executing Cypher queries as part of the Introduction to Cypher course, the query executes but there is no result. It looks like the prompt just refreshes itself and doesn't do anything

4 REPLIES 4

I am facing the same problem

 

RSam3
Node Link

I have found a fix for this issue, IF you are using one of the sign in options such as google, safari, etc. You need to log out of GraphAcademy, and sign in without using one of the options. type in your email and password, and log in. There seems to be an issue with those sign in options not properly logging people in. I am using google chrome, and have not tested this on any other browsers.

I'm using email and password to login and I've tried on both edge chrome and google chrome in incognito and without incognito mode. None of it seem to work to be able to launch the sandbox without issues. 

There is one more thing that I know temporarily fixes it, but has worked multiple times for me. 

First, make sure that you have the sandbox for your course. If its not there just make it. As has been said on other posts, the courses usually require a specific project, such as the movies or the blank sandbox, so make the one you need.
Then, go to the home page for the course, the same page you  were on when you first enrolled. Below the continue course button on the right side of the page, it shows the sandbox it uses for the course. Click on the link just below the title. It will bring you to a page where you can actually input the data you need. The first query should be ":server connect", and in its window it will have a few options.
Make sure the authentication type is 'Username/Password'  then type in the username/password in  the fields below. You can get the  username and  password from the  connection details tab when you have the project selected, from your project list  at sandbox.neo4j.com .
If when you run the query with that information, and return to the course, the query in the sandbox tab should start with "neo4j$" If it doesn't, try doing the excersises in  the project from a separate browser tab. The project you did the ':server connect ' is the same one the course is trying  to connect to,  so you should  be able to run your queries in there.
If  you  really want to have the sandbox tab in the course itself work, I have  found changing the "Connect Url" drop down  from "neo4j+s://" to the bolt option.

This has worked  consistently for me whenever the courses start breaking.

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.