cancel
Showing results for 
Search instead for 
Did you mean: 

Refresh Sandbox

I'm working on the Adding Role Node. I tried to run a query to create these nodes and relationships but made a minor error. However in that script I nulled out the role name in the ACTED_IN relationship already, so I can't try to rerun this again. Is there a way to refresh the sandbox to get it back to starting conditions? I already tried refreshing the page and that did not work.

8 REPLIES 8

I found the Cypher code to put the sandbox back in the correct state. I think this would be a helpful tool though for future classes. It would make it easier to make mistakes and get the database back into working conditions.

Hello @jdbruner.10 ,

I agree. We will look into making the reset of the sandbox easier for users.

Elaine

tick143
Node

Can you share this code? I've done the same thing.

Hello @tick143 and welcome to the Neo4j Community.

The code to refresh the sandbox at the beginning of a Challenge will depend upon which Challenge you are on. If your graph is not validating after a Challenge, the best thing to do is to:

  1. Go to the sandbox site and terminate the sandbox for the course. (right down arrow to see the sandbox actions)
  2. Refresh the Challenge page in the course. It will take a minute or so the the new sandbox to be created. (wait until you see $neo4j in the embedded sandbox pane.
  3. Always use the embedded sandbox for your work in the challenges as it has the code to reset the sandbox for the challenge and validate your work.

Elaine

jmontoya
Node

This is all I get in sandbox embedded pane: 

jmontoya_0-1660015121889.png

not working for me.

 

Does the $neo4j prompt eventually appear? Sometimes it takes a minute or two for the sandbox instance to be created and loaded with data.

Do you have a VPN/firewall that could be blocking access? You might try signing out/in to GraphAcademy and clearing cookies.

Let us know if you are still blocked.

Elaine

graphene
Node

The sandbox is also not working for me. It wasn't working when I did the Cypher Fundamentals Graph Academy course last night. And now I'm trying to do the Node JS course and I can't log in to the sandbox that the course creates for me. 

I got this error when trying to connect to Neo4j with server: connect and the authentication credentials the tutorial gave me for the sandbox:
"ServiceUnavailable: WebSocket connection failure. Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. Please use your browsers development console to determine the root cause of the failure. Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket `readyState` is: 3"
 
After trying a few times I'm getting this error: " Neo.ClientError.Security.AuthenticationRateLimit: The client has provided incorrect authentication details too many times in a row."
and when I go to the sandbox main page and try to create a project with one of the datasets, its fails with this message: 
"

Something went wrong!

Its something wrong on our end. We've logged the error and will get on it right away!

Sorry about this!"


Is the whole sandbox down? Any idea when it might be back up?

I suggest that you sign out, clear cookies, and sign back in.

Elaine