cancel
Showing results for 
Search instead for 
Did you mean: 

Download datasets

Hello

Is it possible to download the training sets used in the graph academy? SO I can load them into my local neo install.

Thanks

11 REPLIES 11

Hello Paul,

The intro course has a browser guide and or CSV files to import so you can host the data locally.

Are you referring to the Applied Algorighms course or Data Science course?

Those courses use specialized sandboxes.

Here is a link to the yelp data set that we use for the sandbox:

https://s3.amazonaws.com/neo4j-sandbox-usecase-datastores/v3_5/yelp.db.zip

I will need to track down the dataset for the Citations sandbox used for the Data Science course.

Elaine

I just download the citations dataset.
how to import this db file (citations.db) into neo4j ?

Thank you,

The zip file for the citations database is 3.4 so the first thing you should do in Neo4j Desktop is to create a project that has a 3.4 database.

Then do the following:

  1. Unzip the database zip file.
  2. Start the database.
  3. Stop the database.
  4. Click the manage button for the database.
  5. Click the open folder button for the database. This is the location of your Neo4j instance.
  6. In file explorer, navigate to the installation-x.x.x/data/databases folder.
  7. Copy the folder where you unzipped the database to the databases folder.
  8. Delete the graph.db folder.
  9. Rename the to graph.db.
  10. Start the database.

Hi Elaine,

I've tried following your steps but it hasn't been working for me.

  1. How do you create a project that has a 3.4 database? When I create a project, it seems to default to 4.05 and the option to "Downgrade to this version", i.e., 3.4, is greyed out?

  2. Ignoring the former issue, when I follow the remaining steps exactly -- save for the name being neo4j rather than graph.db as that is what appears in my databases folder -- I get the following error in the Neo4j Browser: "Database 'neo4j' is unavailable. Run :sysinfo for more info."

Any help on this matter would be greatly appreciated.

Thanks,
Denis

Thanks! I also wanted to have this dataset and run the examples locally

You need to create a 3.4.x database.

Here is an example where if I select a 3.4.o8 database, Neo4j Desktop will need to download it and install it which will take a few minutes.

There no longer is a manage button for the database, but if you click the three dots to the right of the database name, you will see Manage.

Elaine

Hi Elaine,

Thanks for getting back to me so quickly. That got me a lot further but now, when I delete the graph.db folder and rename the citations.db folder as graph.db and start the database again, I get the following error:
Database failed to start: DB [database-e4bebcc7-b8c7-4d52-a41c-ceb84bdd5b38] 'v3.4.16' exited with status 'KILLED'. Check the logs

I had originally tried it with a v3.4.18 database, and have tried it with both citations.db and yelp.db but am continuously running into the same error. I'm running macOS Catalina if that helps.

Thanks again for your help,
Denis

Just FYI, "Got unknown schema descriptor type '93'" seems to be prominent in the log file.

I just learned that although this database is in the 3_4 directory, it is actually a 3.5 database.

I just tried it with 3.5.18 and it starts.

Sorry for the confusion!

Elaine

Ah, excellent, that worked for me too.

No problem re: the confusion and thanks again for your help.

Denis