cancel
Showing results for 
Search instead for 
Did you mean: 

Cannot create new database from dump-file

karlheinz_leder
Node Link

I'm in the online training "Applied graph data science for web applications".
Download of the dump-file "yelp-40.dump" was successful. Import in the new project (Yelp) was successful. When I click the 3 dots of the file-area, there is no menuepoint to create a new database from the dump-file.
What's going wrong?
These are the menuepoints I get:
3X_e_f_ef2c9a2e0d973b4ba73fda991fcd9c6db8ed94ed.png

33 REPLIES 33

FourMoBro
Node Clone

Asked and "solved" here...

karlheinz_leder
Node Link

thanks a lot, it seems I have to wait...

i'm pretty bummed, too

One solution would be for you to use the neo4-admin tool to create the database from the dump file.

  1. For the started DBMS (must be the same version as the dump file), select the terminal window for the started DBMS.
  2. Type the following to create the database: bin/neo4j-admin load --database= --from=
  3. Then in Neo4j Browser:
    :USE system
    CREATE DATABASE ;

Hopefully that will work for you.
Elaine

Dear Elaine @elaine.rosenberg & Neo4j team,

I'm also facing the same issue (cannot create new database from dump file). I tried your solution, but I'm getting error message "bin is not recognized as an internal or external command". In general if I use cmd, I can overcome this error by adding the path to environment variables, but since I'm using Neo4j terminal, I'm not sure how to handle this, could you please help me out, thanks.

Have you opened Terminal from an existing DBMS?

In that window, there should be a bin folder.

What is your platform?

Elaine

Thanks for responding. I'm using Windows 10. When I selected Database-->Open Folder-->DBMS. It takes me to the folder directory and I could find the bin folder inside it.

I've created a new project named "Yelp Project", then uploaded the yelp dump file in it, however I'm not getting the option "Create new DBMS from dump"(unfortunately that feature is not available in desktop version). So I selected Add --> Local DBMS and created a database. But when I open Neo4j Browser, there are no nodes and relationships. Are there any other ways to load the data from dump file? (kindly refer below snapshots)


1. You created a new placeholder for Yelp database. If you open the db in browser you will
 see neo4j and system databases.

2. Database-->Open Folder-->DBMS. Here you will see data/dumps folder 

3. Copy yelp-41.dump file to data/dumps folder

4. Close the browser. Click on ... and select Terminal.

5. Terminal window shows up. Enter this command:
bin/neo4j-admin load --from=data/dumps/yelp-41.dump  --database=yelp-41 --force

6. If successful, close the Terminal window and open the db in browser.

7. Click on the database icon on top left to see the databases from the dropdown box. 
Here you will not see yelp-41 db.

8. Select 'system' database. On the right pane run this Cypher:
CREATE DATABASE yelp-41 and execute the Cypher.

9. Run SHOW DATABASES and you should see yelp-41 and check the status. Status should be 'online'.

10. Select yelp-41 from the dropdown list. Once selected you should see all the nodes, 
relationships on the left. Now you can start playing with it!! 

Dear @ameyasoft
I followed your steps and everything goes good.

Thank you very much for helping me

@elaine.rosenberg @ameyasoft I tried to load panama papers dataset in Neo4j desktop using the dump file, I followed all steps, but after creating the database, it says database is unavailable and status is offline. However when I check the import folder, the database was available inside it.
Can you please help me out with this, thanks.

Thank you, it works for me after several tries because I was confused. I will update with some screenshots.

Hello @madkar777,

Welcome to the Neo4j Community!

These steps are from our "legacy" Graph Data Science course that we are no longer maintaining for updates on GraphAcademy - Neo4j Graph Data Platform

It is indeed important to ensure that whatever dump file you are using to create the graph matches the version of the Neo4j server you are using.

We do have a few new courses on our new GraphAcademy site related to Data Science with more to come:

Elaine

Do you see a bin directory? (dir command)

What if you type ./bin/neo4j-admin....?

The other thing that could be a problem is the directory name that is blacked out. Does it contain a space? Sometimes java processes don't handle paths with spaces.

You must specify a name for the database and the from file must be the absolute path to the dump file.

Elaine

./bin gives "." is not recognized as an internal or external command.
/bin gives The system cannot find the path specified.
Finally I tried including the complete path and it worked.

Thank you very much for helping me @elaine.rosenberg

Followed the same steps but getting error archive does not exist. Can u please help me with it

You must specify that the creation is for a 3.5 database. Did you do that? You cannot have a 3.5 database created in a 4.0 Server.

Elaine

My bad, the dump file is for Neo4j 3.5.14, but I created the latest database 4.2.5. Anyways there is no 3.5.14 version available in Neo4j Desktop
Actually I would like to explore the Panama Papers dataset, I downloaded the dataset from ICIJ and loaded the csv files into Neo4j, all nodes were created successfully(there were around 754000 nodes, but when I created relationship, it was taking a very long time(more than 20 min, it was running), so I closed it and looked for some alternate methods to load the panama papers data.

Could you please suggest some other ways to load Panama Papers data into Neo4j Desktop.

You should be able to create the database from 3.5.14 dump file using the latest 3.5.x version in Neo4j Desktop. Does that not work for you?

Elaine

I tried using 3.5.20, I'm not able to change the database to system, it shows no multi database supported. Also there was no dumps folder, so I created it manually and placed the dump file inside it. And in the terminal window, it shows you need to stop the Neo4j Database and run. I tried stopping database and run, but I got FileException Error.

I am using Neo4j Desktop 1.4.3 (on a MAC), hopefully this works on windows...

  1. Create a new project.
  2. Add dump file for the 3.5 database to the project.
  3. From the dump file select create DBMS from dump file.
  4. Enter a password (optional name), and select the latest 3.5.x release (I selected 3.5.27) - note that it will need to download that release.
  5. Click Create.
  6. Start the DBMS.
  7. Open with Neo4j Browser.

Elaine

This way, the created database name will be the default 'neo4j'

I added the database to Neo4j 3.5.27 in the terminal successfully, then I opened the browser to create database using the command : CREATE DATABASE, but this command is not supported in version 3.5.x. I went through the Neo4j 3.5 user guides in Graph Academy and it says to update the configuration file, so I changed the dbms.active_database= graph.db to dbms.active_database=icij-panama-papers-35.db. After that it asks to Unbind all the nodes to clear the cluster state using "neo4j-admin unbind". I tried it in the terminal, but I get Database locked message. How can I overcome this?


Updating the config file:

@Kevin6482 ,

Is there a reason why you cannot do this in Neo4j Desktop?

It seems like you are really going down into the weeds as you try to rename a database by changing the config file.

Elaine

In Neo4j Desktop, I'm not able to view the databases with Show Databases command. However the same command works fine in version 4.x

Do not confuse 4.x features when you are connected to a 3.5 database.

A Neo4j Server that is 3.5 allows you to have a single database.

A Neo4j Server that is 4.x allows you to have multiple user databases (Neo4j Desktop and Enterprise Edition)

Elaine

Thanks for the clarification, I imported the data successfully.

Whatever you are specifying as the absolute path to the dump file does not exist?

Elaine

Hello, I have the same problem, with ALL my older databases. But for one (neo) open .../import opens even another db:


and then, of course:

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import>load.bat

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import>../bin/neo4j-admin load --from=neo4j.dump --force
Selecting JVM - Version:15, Name:OpenJDK 64-Bit Server VM, Vendor:Oracle Corporation
WARNING! You are using an unsupported Java runtime.
* Please use Oracle(R) Java(TM) 11, OpenJDK(TM) 11 to run Neo4j.
* Please see https://neo4j.com/docs/ for Neo4j installation instructions.
OpenJDK 64-Bit Server VM warning: Option UseBiasedLocking was deprecated in version 15.0 and will likely be removed in a future release.
Archive does not exist: neo4j.dump

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import>dir
 Il volume nell'unità C non ha etichetta.
 Numero di serie del volume: 6039-CEA5

 Directory di C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import

22/09/2021  10.34    <DIR>          .
22/09/2021  10.34    <DIR>          ..
10/03/2021  23.19            37,437 2017.csv
02/06/2021  18.46            67,976 all.cypher
11/06/2020  15.39               169 dump.bat
21/09/2021  21.14                49 load.bat
21/09/2021  09.48         2,824,890 neo4j.dump
               5 File      2,930,521 byte
               2 Directory  21,883,191,296 byte disponibili

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import>

What's wrong? my DBMSs; my neo, dbms-62....30 is in the 8th line:

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss>dir /B
dbms-11cc2619-2c03-4d79-bc51-afae1741d7cb
dbms-23ebda8f-93b7-4822-92f3-eb6ee45158a9
dbms-290fdc29-0c65-4fa3-b11b-435f7f2204f2
dbms-2cefd233-20dc-4599-b664-5c963aa63308
dbms-362268f8-8906-48ac-a8cf-cc79e5e8f61d
dbms-411f4ba1-66ac-4fda-b93f-9ce9d14ad4f4
dbms-5d5b9c0c-0cfa-40dd-80e7-093442721cdb
dbms-622d5abf-f77d-49e0-ac33-f13439776330
dbms-a49444e8-a60d-48d4-b2c0-140941d7ac88
dbms-bd443844-85b0-4f91-b3e2-8bc6b6a5f768
dbms-e6f10bc1-81cb-4ab6-be51-cd6a38fd6e0c
dbms-eb711dd2-2f60-419d-92ba-fad5b0e0724f
dbms-fac2e37d-5a23-4f9c-ac5f-276122bccb26

the neo4j.dump comes from Aura. A totally new db takes this dump.
It must be a confusion of the json which defines the project,

thanks
WJI

Can you specify the full absolute path to the dump file, rather than neo4j.dump?

Elaine

wolfgang_irler
Node Link

Elaine,
thanks you for your comment. Indicating the entire path for the dump file does the job, But as you can see, I'm the right import dir and neo4j is definitively there, but neither ./neo4j.dump nor neo4j.dump is found, yet the ../bin/neo4j-admin is ok. This is an inconsistence of file identification!
Look at the second line of my first scan where the former load.bat is shown.

BTW, of course repeating the whole path for the same directory works:

C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import>../bin/neo4j-admin load --from=C:\Users\w_irler.CLESIUS\AppData\Local\Neo4j\Relate\Data\dbmss\dbms-622d5abf-f77d-49e0-ac33-f13439776330\import\neo4j.dump --force

but is clumsy and redundant, the admin should correctly identify ../ together with ./
WJI

wolfgang_irler
Node Link

Elaine,
AND the details for the db in the rightermost tab panel don't change, even when I added new nodes which was possible. I have Neo4j-Desktop - 1.4.8 and neo 4.3.3. the problem appeared after upgrading from 1.4.7.
Yet after trying to upgrade this db (dbms-622d5abf-f77d-49e0-ac33-f13439776330) to neo 4.3.4 , all data disappeared, remaining only the import dir.
FinallyI removed this confused db. Another db upgrade is ok.
WJI

leah
Node

@elaine.rosenberg I would like to do a data dump but the Neo4j I am doing it from is from an older version..and I realised I can't seem to find the neo4j-admin tool in the path /var/lib/neo4j/bin> Kindly assist.

Hello @leah,

Welcome to the Neo4j Community!

What version of Neo4j are you working with?

Elaine

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

On November 16 and 17 for 24 hours across all timezones, you’ll learn about best practices for beginners and experts alike.