Showing results for 
Search instead for 
Did you mean: 

BoltConnectionError in Graph Academy course

Node Link

I am trying to finish the import CSV course but the sandbox doesn't load. All I get is "BoltConnectionError: No connection found, did you connect to Neo4j?". How should I connect to the sandbox from here?



I recall having an issue were the sandbox stop working. I was told to delete the sandbox and it will create a new the next time you start the course it work for me. Unfortunately, you lose whatever work you completed. Maybe someone else has a better idea, but this is an option. It worked for me.

Thank you for the recommendation, I was thinking the same as well. I just tried terminating the sandbox then refreshing the page so the lesson creates a new one. A sandbox is created but the connection error persists.

Just guessing now, but maybe closing the browser, logging back onto the course, and choosing continue. Maybe the browser is caching the bolt url.

Hello @mjaber995 and welcome to the Neo4j Community!

Are you saying that you were going through the course successfully and when you resumed, you received the bolt connection error?

Did anything change from one GraphAcademy session to another?

You might try deleting all cached pages and cookies as there may be some stale connection information.

Terminating the sandbox in typically does the trick.

If you still continue to receive the bolt connection error, can you try opening a developer console in your browser to see if there are any errors raised?


Hi Elaine,

I tried terminating multiple times but no luck. The only thing that worked for me is to open the course in a private window so it's possible that some cached information that's messing things up like you suggested.