cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Unable to load the POLE dump file into Neo4J Desktop/ Browser

I have tried all possible ways to load the pole.dump file into Neo4J :
I have been doing the following for past 3 days now:

1. Opened the Neo4J Desktop and Using the Add Drop-Down Menu , I have added the pole.dump into the Neo4J Desktop.

2. Then I have selected the Import dump into existing DBMS -> which is my Graph3 Database.

3. Then I am going to Neo4J Desktop and from the Database Information, I selected the pole database but I am getting this error
```
Database "pole" is unavailable, its status is "offline".

```

4. I also tried this: https://community.neo4j.com/t5/graphacademy-discussions/cannot-create-new-database-from-dump-file/td...

i. Database-->Open Folder-->DBMS. Here you will see data/dumps folder

ii. Copy pole.dump file to data/dumps folder (**Although there is no folder called dumps in the data folder**)

iii. Close the browser. Click on ... and select Terminal.

iv. Terminal window shows up. Enter this command:
bin/neo4j-admin load --from=data/dumps/pole.dump --database=pole --force

v. If successful, close the Terminal window and open the db in browser.

vi. Click on the database icon on top left to see the databases from the dropdown box.
Here you will not see pole db.

vii. Select 'system' database. On the right pane run this Cypher:
CREATE DATABASE pole and execute the Cypher.

viii. Run SHOW DATABASES and you should see pole and check the status. Status should be 'online'.

ix. Select pole from the dropdown list. Once selected you should see all the nodes,
relationships on the left. Now you can start playing with it!!


But I could not pass after point **iv** as it says in the neo4j terminal if I open it from the Neo4J Desktop , that it could not load - in fact it says there is a parsing error.

I did check with the following:

```
C:\Users\Chirantan\.Neo4jDesktop\relate-data\dbmss\dbms-11aabb23-daca-4d35-9043-6c039d133a34\bin>neo4j-import Graph3 load --from=data/dumps/pole.dump
'neo4j-import' is not recognized as an internal or external command,
operable program or batch file.

```


I am coming to this platform because I have tried everything available:

https://neo4j.com/docs/operations-manual/current/tools/neo4j-admin/

https://stackoverflow.com/questions/43839329/neo4j-admin-is-not-recognized-as-an-internal-or-externa...

https://www.youtube.com/watch?v=HPwPh5FUvAk

But could not get any luck.



0 REPLIES 0