Showing results for 
Search instead for 
Did you mean: 

ServiceUnavailable: WebSocket connection failure after :server connect for neo4j

I want to launch Neo4j on my machine with dokcer. I downloaded it and did it:

docker run -p 7474:7474 neo4j

But on http://localhost:7474/browser/ I have:

introducir la descripción de la imagen aquí

ServiceUnavailable: WebSocket connection failure. Due to security constraints in your web browser, the reason for the failure is not available to this Neo4j Driver. Please use your browsers development console to determine the root cause of the failure. Common reasons include the database being unavailable, using the wrong connection URL or temporary network problems. If you have enabled encryption, ensure your browser is configured to trust the certificate Neo4j is configured to use. WebSocket readyState is: 3

I tried with neo4j/neo4j credentials and it gave me the same error.

I thought to edit $NEO4J_HOME/conf/neo4j.conf and uncommenting:

# To have Bolt accept non-local connections, uncomment this line:

as they say in the following method but I was not able to find the file

bash-5.1$  cd /var/lib/
abrt/                  games/                 PackageKit/
AccountsService/       gdm/                   plymouth/
alsa/                  geoclue/               polkit-1/
alternatives/          gssproxy/              portables/
authselect/            hp/                    power-profiles-daemon/
bluetooth/             httpd/                 private/
chrony/                hyperv/                rpm/
cni/                   initramfs/             rpm-state/
color/                 iscsi/                 samba/
colord/                kdump/                 selinux/
containerd/            libvirt/               sss/
containers/            lockdown/              systemd/
dbus/                  logrotate/             texmf/
dhclient/              machines/              tpm/
dnf/                   misc/                  tpm2-tss/
dnsmasq/               mlocate/               udisks2/
docker/                net-snmp/              unbound/
fedora-third-party/    NetworkManager/        upower/
flatpak/               nfs/                   xkb/
fprint/                openvpn/               
fwupd/                 os-prober/  


Did you manage to fix this issue? I had the some problem and saw this unanswered whilst searching. To fix the problem I needed to login via the cypher-shell to change the password before being allowed to login via the browser.

First start a bash session inside the container:

docker exec -it <container_name> bash

Then start cypher-shell and proceed to login (default user and password is neo4j and neo4j)


Hope that helps!