cancel
Showing results for 
Search instead for 
Did you mean: 

Database dump for Neo4j Desktop 1.4.5 on Ubuntu

I am trying to do a database dump from Neo4j Desktop 1.4.5. Unlike in previous versions there is no ‘dump’ option in the management panel. I tried using the terminal:
neo4j -admin dump —database=graph.db —to=~/Downloads/dumptTst/

But I got this error:
‘ command failed: you do not have permission to dump the database — is Neo4j running as a different user?’

I am the only user and I don’t see any place to authenticate.

Then, instead of doing a database dump, I tried to export the database to CSV or json using apoc. But I looked everywhere and can’t find the apoc config folder and won’t be able to export to CSV or json without that.

After that, I tried a command like this:
MATCH (n)
RETURN n
To return all of the nodes using simple Cypher. (I was going to do the same for the relationships.) But it was too much data and crashed.

I tried the apoc periodic commit but that didn’t work either.

Any help would be appreciated!

1 REPLY 1

Did you stop the database before running the dump command?

--to needs a filename not a folder

You can add an apoc.conf to the conf folder or just add the setting in neo4j.conf