cancel
Showing results for 
Search instead for 
Did you mean: 

Using apoc function with embedded database

paulB
Node Clone

Hello,

Currently working with Spring Data Neo4j, I'm using neo4j in 4.4.4.
I need to use an apoc coll function in a test. As this function is not bring by a simple import, I need to import in my pom.xml apoc with classifier all :

    <dependency>
	  <groupId>org.neo4j.procedure</groupId>
      <artifactId>apoc</artifactId>
	  <version>4.4.0.3</version>
	  <scope>test</scope>
	  <classifier>all</classifier>
	</dependency>

But this bring an old version of neo4j Driver (4.0.0) witch create conflict and result in unexecutable query.
It seem that this old version of neo4j is used for all latest apoc version.
Is there any chance for this to be updated?
Is there any way of getting only procedure and function class from the repository?

In advance thank you for your help.

1 ACCEPTED SOLUTION

paulB
Node Clone

This problem will be solve soon. See the question here on the projects github :

View solution in original post

1 REPLY 1

paulB
Node Clone

This problem will be solve soon. See the question here on the projects github :