cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Neo4j go driver with bolt protocol version 1

We are having a graph database which supports only bolt protocol version 1. I am trying to use the GitHub - neo4j/neo4j-go-driver: Neo4j Bolt Driver for Go for my use case(building a cli)

But it gives error as : Server did not accept any of the requested Bolt protocol version

Even the older versions(1.8.3) of go driver gives the same error. Am I missing something here ? or this driver not support bolt protocol version 1 at all ?

  • Go
2 REPLIES 2

Hello,

If I'm not mistaken, Bolt protocol v1 was released for Neo4j server 3.0.

Neo4j 3.0 has been outdated for a very long time, so you should at least upgrade to 3.5 which is going to be maintained for a few more months and will work with recent drivers. Not upgrading the server is a security liability.

Maybe the Go driver 1.7.4 will work, but same warning as before: these versions are not maintained anymore and are built on top on an unmaintained C library (seabolt).

Which version of Neo4j server are you using?