cancel
Showing results for 
Search instead for 
Did you mean: 

Join the community at Nodes 2022, our free virtual event on November 16 - 17.

Graphql install Button greyed out

biYTccKCiu
Node Clone

I've usually developed and played on my mac but I decided to run neo4j desktop on my windows pc. For the life of me I can't recollect if I had to downoad the plugin for graphql manually. Even when I re download it on the mac, the install button is there and works..

Can anyone advise?

8 REPLIES 8

Can I suggest you click Manage, then Plugins on the Neo4j database you wish to add GraphQL to.
2X_4_4c646a9d1349293d5d796952c1529f79833138f5.png
Then install it from there. If you have multiple versions of Neo4j for single project, then sometimes it can't determine which version to download.
What version of Neo4j are you trying to install GraphQL on?

Desktop version 1.2.1

Going to manage plugins didn't work as you can see by the screenshots... I could try and delete app from pc and restart reinstall and see if its there. but curious to know if this behavior is just because I'm making a mistake somewhere..

Hi @biYTccKCiu -

I updated the list of Neo4j versions that are supported by the GraphQL plugin. Could you try refreshing Neo4j Desktop and trying to install the GraphQL plugin again?

I am having a similar problem...how do I install the plugin?

sudosharma
Node

For anyone else experiencing this issue, the Neo4j-GraphQL Extension was deprecrated a while back:

This is a note from the associated GitHub repo:

"The plugin is considered end-of-life. It will not be updated for Neo4j 4.0, we recommend to move a middleware based solution using neo4j-graphql-js or neo4j-graphql-java. After a lot of feedback we think separating the GraphQL API from the core database is the better architectural setup."

The recommended approach is to use something like neo4j-graphql-js.

clem
Graph Steward

A mark of a good UI, is if you rarely have to do something, that you can still figure out after not doing it for months.

I somehow managed to install APOC for a previous database before. Now that I've created a new one, I can't remember what I did.

I also cannot find the Manage button anywhere that @david.rosenblum mentioned.

In general, if there's a dimmed button, a good UI design will allow for a user to easily figure out how to undim the button!

The fact that there are three people getting confused by this is a clue that the UI design is suboptimal in some way....

[added]
I finally figured it out, but my comments are still valid.

You have to click on the Left Pane for "Applications Settings", and then uncheck "Enable offline mode".

That was pretty obscure for something that is rarely done but important. I'm still not sure about the Manage button though.

I filed this issue

We always welcome product suggestions, but my answer is from November 2019. I'm not really sure what version of Desktop you are on currently.

If you upgrade to 1.4.5 of desktop, the offline button will be gone, and with it hopefully the issues that went with the software figuring out if it is offline or not. And since the offline button is gone, well your suggestion may not be correct either.

The UI has changed since my post, so my directions are invalid. I accept that.
If you highlight the database name you will see another panel with options and menus. The latest Desktop Guide is available in Desktop (the ? tab) or here: Neo4j Desktop - Neo4j Desktop
GraphQL is not available as a plugin for 4.x - you can see the comments above.
There is an excellent Training Academy for GraphQL available here: Building GraphQL APIs Using The Neo4j GraphQL Library - Neo4j Graph Database Platform

Hope this helps

I was on Browser 1.4.1. I just upgraded to Browser 1.4.5 and now the offline button seems to be gone. Thanks.