Error using py2neo NodeMater

This code will cause error.

n = NodeMatcher(g)
node= Node("Person", age= 20)
g.create(node)
node = n.match("Person").where(age=20).first()

ClientError : SyntaxError: Invalid input '{': expected "+" or "-" (line 1, column 32 (offset: 31)) "MATCH (_:Person) WHERE _.age = {1} RETURN _"

4 REPLIES 4

rouven_bauer
Neo4j
Neo4j

Looks like what's written in the docs. Are you running on the latest version of py2neo? If not, try updating it. Else, this might be a bug worth opening an issue for on py2neo's GitHub page.

I am especially confused about WHERE _.age = {1} being in the query while you query for age to be 20.

rouven_bauer
Neo4j
Neo4j

Oh wait. Looks like a format sting that got not properly populated

Thanks for helping!
I'm currently using the 4.2 version, I could upgrade to the latest version, but then it will face another error of "OverflowError: mktime argument out of range" when import Graph.
So I think this cannot help

rouven_bauer
Neo4j
Neo4j

I'm still not deeply involved in py2neo, but it looks like the OverflowError has been resolved Getting 'OverflowError: mktime argument out of range' while importing the database module from lates... Maybe, an upgrade is viable now.