cancel
Showing results for 
Search instead for 
Did you mean: 

Delete database is not releasing memory Neo4j 4

lakshmi_rdk
Node Link

Hi ,
I have a springboot application that connects to a standalone instance of neo4j. The springboot application runs as a container in a kubernetes cluster and neo4j is deployed in a virtual machine. Our application needs to run on multiple databases in neo4j. As a part of performance testing we are creating around 10 databases. Once testing is done, we delete the databases created( By running "DROP DATABASE ). Even after deleting database we are seeing a huge performance degradation for the application.

Only after a VM restart performance comes back to normal. Is this expected behavior? Is there any configuration available to reclaim memory that is used by deleted databases?

Neo4J version 4.0 MR2
Java driver:
org.neo4j.driver
neo4j-java-driver-spring-boot-starter
4.0.0-beta01

2 REPLIES 2

anthapu
Graph Fellow

I would suggest using the GA version of 4.0 and try again.

Also, would it be possible to post debug log of the server to see what is happening?

Thanks
Ravi

lakshmi_rdk
Node Link

I tried GA version and GC seems to be working fine. But still not sure while file handlers are closed properly. I am using Halin to monitor my Neo4j. It shows 60k available and ~6k used. But in metrics window it shows only 13% file handlers are free. Not sure if its issue with Helin report. Is there any way to check how many file handlers are used by neo4j process?