cancel
Showing results for 
Search instead for 
Did you mean: 

Head's Up! Site migration is underway. Phase 2: migrate recent content

Setup for Advanced Hands on training - graph.db not available

dhaks_r
Node Link

I have received email instructions to setup for this advanced training session.
Basically involves setting up desktop, creating a db, downloading a graph db zip file, copying that into database directory and then starting the db.

The start db console doesnt give any error. It says started. I cant find any error messages in the log files either. However browser/ bloom say that "Database 'graph.db' is unavailable. Run :sysinfo for more info.". Sysinfo is also not able to give any information

BTW - the instructions say choose the database as version 3.5.8.. but my desktop version doesnt allow any version other than 4.0.4. Hope thats the issue

1 ACCEPTED SOLUTION

Joel
Ninja
Ninja

What versions do you see in the 'create db" drop down?

The oldest version I see offered by the latest neo4j desktop client is 3.4.16, is it possible that this is a compatibility range?

These urls imply 4.0 should work with 3.5 though


https://neo4j.com/docs/cypher-manual/current/deprecations-additions-removals-compatibility/#cypher-c...

Note: The previous two neo4j desktop versions are available for download still,
https://neo4j.com/download-center/#desktop
but I could not find a compatibility list for neo4j desktop version with db version

View solution in original post

4 REPLIES 4

Joel
Ninja
Ninja

What versions do you see in the 'create db" drop down?

The oldest version I see offered by the latest neo4j desktop client is 3.4.16, is it possible that this is a compatibility range?

These urls imply 4.0 should work with 3.5 though


https://neo4j.com/docs/cypher-manual/current/deprecations-additions-removals-compatibility/#cypher-c...

Note: The previous two neo4j desktop versions are available for download still,
https://neo4j.com/download-center/#desktop
but I could not find a compatibility list for neo4j desktop version with db version

brentPhillips
Node Clone

I would suggest starting over from scratch. Make sure that after you create the database, you do not start it right then. By starting it then, you will be creating a graph.db, which is not what you want to do. Instead, you will be creating a graph.db in Terminal, You won't be starting the database until you are finished in Terminal. And the version to pick is 3.5.18, not 3.5.8. Not sure why you would have only 4.x.x showing. Interesting.

dhaks_r
Node Link

I followed the steps to ditto. I create a database. I did not start. Copied the zip file via terminal. Unzip and then remove the original. saw the graph.db listed as directory. After that only started the db.

The drop down for DB is showing only 4.0.4
Nothing else. I am using desktop Version 1.2.9 (1.2.9.1718) for Mac OS

I did again fresh. Now in drop down of db, i can see older versions. Selected 3.5.18 and this is resolved. Pl close the problem

Cool! Glad you are up and running.

Nodes 2022
Nodes
NODES 2022, Neo4j Online Education Summit

All the sessions of the conference are now available online