# Unable to run GDS algorithm

**URL:** <https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634>\
**Category:** Cypher\
**Tags:** gds\
**Created:** [October 8, 2025, 5:55am UTC](https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634 "2025-10-08T05:55:38Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![percyjay1998](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/percyjay1998/32/30952_2.png) [@percyjay1998](https://community.neo4j.com/u/percyjay1998)\
**Post date:** [October 8, 2025, 5:55am UTC](https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634/1 "2025-10-08T05:55:39Z")

</div>

neo4j and gds versions:

 ![image](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/b/6/b625e8987dd8c5ad734dcd304121169c6ff3f219.png)

Graph Projection

```auto
CALL {
                    MATCH(nodes:Incident|Query) WHERE nodes.lastTime >= datetime() - duration({days:30})
                    RETURN gds.graph.project(
                        "testgraph",
                        nodes,
                        null,
                        {
                        // Load only the 'feat' vector; labels are optional
                        sourceNodeProperties: nodes { .feat, .geo },
                        targetNodeProperties: {}
                        }
                    ) AS g
                    }
                    RETURN g.graphName AS graph, g.nodeCount AS nodes, g.relationshipCount AS rels;

```

RESULT:

 ![image](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/9/d/9db4ad95d7a3622bf17e53c309a787e088891d0a.png)

Running KNN on stream mode:

```auto
CALL gds.knn.stream("testgraph", {
                nodeProperties: [
                        {feat: "COSINE"},
                        {geo: "EUCLIDEAN"}
                    ],
                topK: 1,
                similarityCutoff: 0.75, // e.g. 0.70
                randomSeed: 42, concurrency: 1, sampleRate: 1.0, deltaThreshold: 0.0
                })
                YIELD node1, node2, similarity
                WITH gds.util.asNode(node1) AS src, gds.util.asNode(node2) AS dst, similarity
                WHERE src:Query AND src.qid = "q_32360_1759902492677_95f53a" AND dst:Incident
                RETURN dst.incident_id AS incident_id, similarity
                ORDER BY similarity DESC LIMIT 1;

```

RESULT: error

 ![image](https://us1.discourse-cdn.com/flex021/uploads/neo4jcommunity/original/3X/0/e/0e2d32599f0517576777e03160128a15010d8927.png)

can anyone please help me fix this error.

---

<div class="post-metadata">

**Author:** ![florentin\_dorre](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/florentin_dorre/32/18241_2.png) [@florentin\_dorre](https://community.neo4j.com/u/florentin_dorre)\
**Post date:** [October 8, 2025, 7:30am UTC](https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634/2 "2025-10-08T07:30:08Z")

</div>

Hello @percyjay1998 ,  
the issue is likely in the configuration.  
The error message tells you its part of the `dbms.security.procedures.unrestricted`setting.  
it should be ``dbms.security.procedures.unrestricted`setting`=gds.*`.

see our [docs](https://neo4j.com/docs/graph-data-science/current/installation/neo4j-server/#installation-neo4j-server-bundled) for more details on how to install GDS correctly

---

<div class="post-metadata">

**Author:** ![percyjay1998](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/percyjay1998/32/30952_2.png) [@percyjay1998](https://community.neo4j.com/u/percyjay1998)\
**Post date:** [October 9, 2025, 4:15am UTC](https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634/3 "2025-10-09T04:15:14Z")

</div>

Hi @florentin_dorre ,  
I did that too. But still getting the same error.

dbms.security.procedures.unrestricted=jwt.security.\*,apoc.\*, **gds**.\*

dbms.security.procedures.allowlist=apoc.coll.\*,apoc.load.\*, **gds**.\*

Just an additional information I am running the neo4j on the docker.

---

<div class="post-metadata">

**Author:** ![florentin\_dorre](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/florentin_dorre/32/18241_2.png) [@florentin\_dorre](https://community.neo4j.com/u/florentin_dorre)\
**Post date:** [October 13, 2025, 11:30am UTC](https://community.neo4j.com/t/unable-to-run-gds-algorithm/75634/4 "2025-10-13T11:30:06Z")

</div>

for the docker setup i use the following environment vars to apply the settings correctly:

```auto
      - NEO4J_PLUGINS=["graph-data-science"]
      - NEO4J_dbms_security_procedures_allowlist=gds.*
      - NEO4J_dbms_security_procedures_unrestricted=gds.*

```

how did you change the settings?

actually, `--env NEO4J_PLUGINS='["graph-data-science"]' ` as shown in [Neo4j on Docker - Neo4j Graph Data Science](http://neo4j.com/docs/graph-data-science/current/installation/installation-docker/) should be enough
