# Unable to load db dump from 3.5.x into 4.x

**URL:** <https://community.neo4j.com/t/unable-to-load-db-dump-from-3-5-x-into-4-x/24576>\
**Category:** Neo4j Graph Platform\
**Created:** [September 3, 2020, 1:02pm UTC](https://community.neo4j.com/t/unable-to-load-db-dump-from-3-5-x-into-4-x/24576 "2020-09-03T13:02:02Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ethrbunny](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/ethrbunny/32/13562_2.png) [@ethrbunny](https://community.neo4j.com/u/ethrbunny)\
**Post date:** [September 3, 2020, 1:02pm UTC](https://community.neo4j.com/t/unable-to-load-db-dump-from-3-5-x-into-4-x/24576/1 "2020-09-03T13:02:02Z")

</div>

Ultimate goal is to upgrade from 3.5.x to 4.x.

Running

`neo4j-admin load --verbose --from=/tmp/db.dump --database=my-data`

or

`neo4j-admin load --verbose --from=/tmp/db.dump --force`

both give me 'database "" is unavailable'. Doesn't seem to matter whether I specify a new name or let it use the default.

When I try `neo4j-admin check-consistency --database=<name from above>` Im told

"Failure when checking for recovery state: Error reading transaction logs, recovery not possible. To force the database to start anyway, you can specify 'unsupported.dbms.tx\_log.fail\_on\_corrupted\_log\_files=false'. This will try to recover as much as possible and then truncate the corrupt part of the transaction log. Doing this means your database integrity might be compromised, please consider restoring from a consistent backup instead."

If I try it on the dump file it gets more entertaining:

```
# neo4j-admin check-consistency --backup=/tmp/db.dump
Report directory path doesn't exist or not a directory: /tmp/db.dump

# ls -al /tmp/db*
-rw-r--r-- 1 root root 41720297 Sep 3 12:34 /tmp/db.dump

```

Anyway - the upgrade from 3.5 to 4.x is confusing. If anyone can shed some light on what I'm doing wrong I'd be most appreciative.

---

<div class="post-metadata">

**Author:** ![joe.schmirler](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/joe.schmirler/32/4370_2.png) [@joe.schmirler](https://community.neo4j.com/u/joe.schmirler)\
**Post date:** [December 8, 2021, 4:53pm UTC](https://community.neo4j.com/t/unable-to-load-db-dump-from-3-5-x-into-4-x/24576/2 "2021-12-08T16:53:22Z")

</div>

I'm having the same issue - any update on this?

---

<div class="post-metadata">

**Author:** ![ameyasoft](https://sea1.discourse-cdn.com/flex021/user_avatar/community.neo4j.com/ameyasoft/32/32639_2.png) [@ameyasoft](https://community.neo4j.com/u/ameyasoft)\
**Post date:** [December 9, 2021, 5:31am UTC](https://community.neo4j.com/t/unable-to-load-db-dump-from-3-5-x-into-4-x/24576/3 "2021-12-09T05:31:43Z")

</div>

Check this document: neo4j-upgrade-migration-guide.pdf.

The neo4j-admin copy command is an Enterprise Edition feature. Therefore, it is not possible to migrate to a Community Edition, for example, from Neo4j Community Edition 3.5 to Neo4j Community Edition latest. However, you can use it to migrate from Neo4j Community Edition to Neo4j Enterprise Edition. (see Chapter 3)
